We changed our privacy policy. Read more.

Questions tagged [alsa]

ALSA (Advanced Linux Sound Architecture ) is an API of audio functions for the linux platform.

Filter by
Sorted by
Tagged with
0
votes
1answer
9 views

How to use persistent ALSA devices?

I followed this guide to set the default device like this: create /etc/asound.conf with following: defaults.pcm.card 1 defaults.ctl.card 1 But I have the problem that the ALSA card numbers are not ...
0
votes
1answer
17 views

Trying to record from a USB sound card

I'm using a UGreen USB External Stereo Sound Card and would like to record the music from some old tapes. I am not able to manage any kind of recording with it. My Fedora recognizes it immediately as ...
0
votes
0answers
10 views

ALSA: How to configure audio CD output for both mono, and stereo CDs?

After a reinstallation of Raspbian Buster I've run into a serious issue with my audio CD output, particularly with setting the output to mono vs. stereo by using this asoundlib method: ...
1
vote
1answer
39 views

Pulseaudio errors - relevant files: Debian

I have inherited software which communicates with a MIDI device, so ALSA and pulseaudio are both involved. On the system B I have built from the ground, there are errors such as No protocol specified ...
0
votes
1answer
60 views

Microphone doesn't work in Arch

I'm using Alsa. arecord -l gives me **** List of CAPTURE Hardware Devices **** card 0: Intel [HDA Intel], device 0: Generic Analog [Generic Analog] Subdevices: 1/1 Subdevice #0: subdevice # ...
0
votes
1answer
14 views

How to set ipc_perm for the default output device?

When I use aplay to play some sound, sometimes I get an error: ALSA lib pcm_dmix.c:1071:(snd_pcm_dmix_open) unable to create IPC semaphore aplay: main:828: audio open error: Permission denied This ...
0
votes
0answers
17 views

amidi error: cannot open port "hw:1": Device or resource busy (ALSA midi)

I am trying to send a direct MIDI reset command (0xFF) to a MIDI keyboard using the amidi utility. Located the Midi device: amidi --list-devices Dir Device Name IO hw:1,0,0 CLASSIC Lighted ...
2
votes
1answer
53 views

Only noise with alsa and pulseaudio

I've tried for multiple days to set up my headphones. Whenever I play something via aplay or speaker-test I only hear very loud white noise. I know it's not a hardware problem, because it worked with ...
1
vote
0answers
23 views

Play remote audio stream on embedded Linux device using ALSA

I have an embedded ARM Linux device with a speaker connected to it. So far I've successfully compiled alsa-lib and alsa-utils and installed on the target system. I can list my device using aplay -l: ...
0
votes
0answers
70 views

Headphones not working on Arch

I am using an Arch Linux distribution with pulseaudio, pulseaudio-alsa. I plug in my headphones and there is no sound. I believe that my computer is recognizing the headphones being plugged in, just ...
0
votes
1answer
20 views

Why pavucontrol does not save the recording device permanently?

I'm doing recording tests for my streaming, I have enabled and as default "Monitor of Built-in Audio Analog Stereo", in old versions of chrome it works perfect, but in the new ones I have to ...
0
votes
1answer
66 views

Audacity only hears system sounds

Audacity only hears system sounds. It is not capable of receiving microphone input. In alsamixer, every option is unmuted and set to the maximum. In PulseAudio Volume Control, the visual indicator ...
0
votes
0answers
83 views

How to fix Archlinux not recognizing headset michrophone via headphone jack?

My audio card: HDA Intel PCH My chipset: Realtek ALC887-VD What I've tried: Installing Alsa and Pulseaudio audio drivers. Experimenting with the audio drivers. Looking at several forums (nothing ...
0
votes
0answers
138 views

Simultaneous digital and analog output on pipewire

i'm currently trying to configure pipewire to use both digital and analog output at the same time with different streams, like in windows. In pavucontrol currently i have to switch between "...
0
votes
1answer
67 views

Change default recording sample rate for "arecord"

I'm attempting to change the default sample rate when recording audio with arecord. Currently, when running arecord test.wav the rate is 8000 Hz: arecord test.wav Recording WAVE 'test.wav' : Unsigned ...
2
votes
1answer
90 views

What is the ideal way to play-through or monitor audio input using arecord, parec or jackd?

I have failed to pipe the recorded audio input on my audio device (an alsa driven hifiberry with an adc hosted on a raspberry pi) despite trying my best to pipe the output into tee after arecord, ...
1
vote
0answers
90 views

Audio is garbled - alsa-pcm front:2: snd_pcm_status error: Broken Pipe

Running on Fedora 34, all up-to-date. This is a new install as of a couple weeks ago. Computer is relatively new, on a good SSD, plays on Windows fine even with heavy usage, so this shouldn't be a ...
1
vote
0answers
118 views

No sound over HDMI with Nvidia GPU

Disclaimer: yes I know there are tons of posts on this and other forums about pretty much the same. I have been through many of them and I can't figure out what is wrong. Any help would be appreciated....
0
votes
0answers
21 views

Get applications using microphone in pop os 20.04

I am trying to make microphone usage indicator to show on my polybar if any application is using microphone. Is there a way I can get which applications are using microphone from pulseaudio or alsa.
1
vote
1answer
56 views

Write audio stream to an ALSA device with ffmpeg

I used snd-aloop module to create a loopback audio stream. Now I want to somehow mux my desktop audio from pulseaudio and my microphone audio streams into this loopback stream, and while that can be ...
0
votes
1answer
92 views

Can I configure PulseAudio or ALSA to treat the surround audio ports as normal headphones?

I am hoping to work around the fact that my normal headphone jack is broken and doesn't pick up headphones very well at all. My thought is that it might be possible to use the surround ports on the ...
0
votes
0answers
60 views

Pulseaudio loopback resample distortion

I have a rather complex PA setup, across two machines. One, a desktop, does not run a pulse server. client.conf on that machine looks like this: (Comments are not included) autospawn = no default-sink ...
0
votes
0answers
159 views

audio: Unknown audio driver `jack' audio: warning: Using timer based audio emulation while I'm trying to configure pipewire / jack with a qemu VM

Does anyone run pipewire with their VFIO setup? I want to stop using pulseaudio but I'm having issues with the correct configuration of pipewire (and jack). My goal is to hear sounds inside the Ubuntu ...
0
votes
0answers
68 views

Microphone working but not shown in gome-settings

I have a microphone connected to an audio interface which is completely working. Output works fine and the input also works fine in every application which allows to select the device (firefox, zoom, ...
0
votes
0answers
324 views

Changing the sampling rate in ALSA/Pulseaudio Ubuntu

i have tried every possible method to change the sampling rate from 44.1Khz/48Khz set in pulse audio and ALSA. I have tried 3 different OS such as Ubuntu 20.04, Ubuntu 16.04 and Raspberrian. I have ...
1
vote
1answer
68 views

How can I determine what configuration is required to make a Rodecaster Pro work? Could be some ALSA resampling issue

I want to use a Rodecaster Pro mixer to run my audio. It runs fine on my laptop, but not on my desktop (both running Ubuntu 20.04 with kernel 5.8.18). On my desktop, the input from microphones are ...
0
votes
0answers
39 views

Record audio output directly from soundcard bypassing mic

I own a Lenovo Thinkpad L440. I would record soundcard output directly, not from internal mic. I have alsa as sound system and running alsamixer contents it returns to me this: numid=23,iface=CARD,...
0
votes
0answers
29 views

How to get my Pi zero audio simultanusly on my hifiberry and on ffmpeg?

Hope you can help me. Got a Pi Zero and Hifiberry Module playing with raspoitify. Speaker sound is fine. My goal is to have the same (raspotify) audio on a ffmpeg stream from that Pi as well. I ...
0
votes
0answers
25 views

Requesting assistance with Ubuntu Studio 20.04 "Jack" Audio

I need assistance with my Gateway laptop (MD7818) which is a dual-boot configuration with Windows 10 and Ubuntu Studio 20.04. I have been unable to get the audio to configure properly while using ...
1
vote
0answers
35 views

Front-panel headphones are detected, but not working

When I plug headphones into the front-panel jack, pavucontrol detects them as such (Output Devices > USB Audio Analog Stereo > Port: Headphones (plugged in) when present, vs Port: Digital Output ...
0
votes
1answer
72 views

Built In Speakers do not work, headphones do, USB speakers do

I have an HP All-in-one, (HP Pavilion All-in-One 24-xa0xxx), and everything has appeared to work on linux, except the built in speakers. The headphone jack works fine. I am running Arch Linux, but ...
0
votes
0answers
750 views

Getting ALSA cannot find card '0' whilst trying to play audio files on my VPS Debian server

I am trying to play audio on a Debian server with sox. But I get these errors: ALSA lib confmisc.c:767:(parse_card) cannot find card '0' ALSA lib conf.c:4568:(_snd_config_evaluate) function ...
0
votes
1answer
84 views

How to change the output file of a pipe without stopping

I am using arecord to get audio files to preform DSP on. The problem is that everytime I start to capture input from my i2s microphone, there is a 1 second pop at the beginning of the file. I am ...
0
votes
1answer
19 views

Alsa-lib kernel options

I'm installing Qt to install KDE on my VMware LFS virtual machine. The BLFS guide says to do some kernel configurations appropriate for the hardware, but I don't know what things should I enable and ...
1
vote
1answer
114 views

Kali: Sound Card not Detected

I recently purchased a new laptop with windows and proceeded to install linux (first Arco then Kali) and encountered problems with the sound card not being detected (on both distros - both used Gnome ...
0
votes
1answer
47 views

Explanation of Linux/Udev Audio Device Naming

Given the following code: struct udev *udev_obj = udev_new(); struct udev_enumerate *udev_enum = udev_enumerate_new(udev_obj); udev_enumerate_add_match_subsystem(udev_enum, "sound"); ...
0
votes
0answers
28 views

Using Udev Sound Device with ALSA

Inside of a C program, using libudev and libasound, I have determined a struct udev_device *device is part of the sound subsystem with udev_device_get_subsystem(device) == "sound". Now I ...
0
votes
1answer
125 views

Configure alsa pcm.dmix.rate for a perticular card?

folks. I have an external USB sound card witch may, or may not present in the system depending on my actual location. Previously I used this card as default, so configuration like the following worked ...
0
votes
0answers
85 views

Odroid N2plus Alsa playing sound through HDMI

I'm having a hard time setting up ALSA on Ubuntu 20.04.2 LTS server running kernel 5.11.0-odroid-arm64. The user is a member of the audio group. Only ALSA is installed on the system. It is a KMSDRM ...
0
votes
0answers
25 views

aplay --list-pcms gives no output

I am having problems with my soundcard and i've been checking what is missing: since aplay --list-pcms gives no output that implies that there are no pcms(?) which i think it may be one of the reasons ...
1
vote
0answers
47 views

systemd-modules-load failed to find module for soundcard

My soundcard won't reproduce any sound nor receive it. I was looking at the journalctl and this popped out: Mar 07 20:14:16 debian systemd-modules-load[204]: Inserted module 'snd_hda_intel' Mar 07 20:...
1
vote
0answers
104 views

Pavucontrol shows that audio is playing but no output heard

I have a problem that has been bothering me for a week now: I have installed debian 10 (buster)(32-bit) on an acer aspire 1610 and i am having problems with the audio card: essentially pavucontrol ...
0
votes
0answers
88 views

No sound from laptop speakers: a problem on my Dell XPS 9370 on multiple distributions

This is a long-time issue with my laptop, as in the last year or so. The laptop, a Dell XPS 13 9370, is about 3 years old. When an application plays sound, nothing comes out of the speakers. This is ...
0
votes
0answers
44 views

Alsa/pulseaudio no sound

I am working on debian (10 buster) that has issues in playing audio trough the speaker device: The audio card worked fine until i plugged an nvidia card with hdmi puvacontrol gives output on the ...
0
votes
0answers
3 views

Command to turn sound controller/sink on/off?

It is possible to turn sinks and output on/off in puvucontrol configuration tab. What would be the command to do that? Non of pulse cli syntax seems to correspond.
1
vote
0answers
136 views

Recording screen with pulseaudio causes desyncs

Following the ffmpeg's Capturing Desktop guide for linux, when audio source is pulse format it causes frame freezes and desyncs, fps slows down, and video is delayed compared to audio. I have tried ...
0
votes
0answers
24 views

How to debug audio cards (missing recording channels)

I have a StudioLive AR8 USB mixer by PreSonus that also functions as an audio card. What is so neat about this is that I get 2 playback channels and 4 recording channels! (1× stereo playback, 2× ...
0
votes
0answers
65 views

failed to simultaneously call aplay and arecord with alsa

for my project, I'd like to call arecord and aplay simultaneously like the following: aplay -d 20 signal.wav & arecord -c 2 -d 20 -f S16_LE -r 48000 speaker_response.wav so that when a test ...
2
votes
1answer
156 views

aplay lists the device, but pulseaudio thinks it's locked and won't detect it

UPDATE 2021-07-08: I'm now using Pop!_OS 21.04 and this problem appears to have been resolved. I have just now tested with pulseaudio 14.2 and pipewire 0.3.24 and I was able to disconnect and ...
1
vote
1answer
89 views

Audio output busted after installing debian-pulseaudio-config-override

I'm using Devuan GNU/Linux 3 Beowulf. My machine has on-board audio (an Intel board). Audio used to work from most apps, including Chromium, but not including Firefox strangely enough (it wanted ...

1
2 3 4 5
14