Linked Questions

9
votes
1answer
3k views

Still alive, still alive after kill -9 / SIGKILL [duplicate]

An apache2 process got stuck on my server and caused problems with other services. (original problem: kerneloops after USB hardware disconnect) root@server:~# ps aux | grep apache2 | grep -v grep ...
7
votes
2answers
5k views

kill -9 hangs, unable to kill process (murder proof process) [duplicate]

Possible Duplicate: What if ‘kill -9’ does not work? I guess its a bit late to ask this, but for future reference; I was called to look at a server today after a customer was reporting that ...
2
votes
1answer
26k views

kill pid is not working? [duplicate]

This is pretty weird now. I am trying to kill a process by using its pid but it is not working at all. root@machineA:/home/david# ps aux | grep modelling david 5075 0.0 0.0 1285420 29404 ? ...
0
votes
1answer
6k views

How to force a PID to terminate? [duplicate]

Yes, I've tried all the basic kill, pkill, etc. methods that come up with a Google search. Sometimes it works, other times it seems something is preventing the process from terminating. There is no ...
1
vote
1answer
3k views

D state process kill [duplicate]

There is a D state process (stuck) which is not killed even by kill -9. I see PPID is systemd. root 1863 1 0 **Ds** /usr/sbin/smartd -n root 1 0 0 **...
2
votes
1answer
2k views

kill -9 cannot kill process with parent PID = 1 [duplicate]

I have a process with parent PID = 1. The command kill -9 382 doesn't work. I am root. What can I do? root 382 1 0 07:29 ? 00:00:00 dsmrecall /ptstv/HVideo/2014/2014761/...
0
votes
1answer
287 views

Cannot kill process rgmanager [duplicate]

I have # ps aux | grep rgmana root 4209 0.0 0.0 0 0 ? D< gen26 4:25 [rgmanager] the # kill -9 4209 has no effect. Only reboot solves the issue. Could you please ...
0
votes
0answers
45 views

System process running in R state, strace doesn't show any output and isn't killing it -9 [duplicate]

So as in image the process running in R state. Not able to kill them with kill -9. Also strace isn't showing any output. What can be the reason for this and is there any option other than restarting ...
0
votes
0answers
33 views

How to terminate a process when kill -9 doesn't work? [duplicate]

I've seen a few cases of processes that don't respond to kill -9. Most recently, I've seen both lsusb and reaper get stuck and be unresponsive to kill -9. (After trying all the usual signals first) ...
406
votes
9answers
172k views

When should I not kill -9 a process?

I am always very hesitant to run kill -9, but I see other admins do it almost routinely. I figure there is probably a sensible middle ground, so: When and why should kill -9 be used? When and why ...
36
votes
1answer
14k views

Difference between less violent kill signal -HUP (1) -INT (2) and -TERM (15)

Apart from the most violent kill -9 (SIGKILL), I don't quite understand the difference between the 3 other common signals (here) -HUP (1), -INT (2), and -TERM (15). In which scenarios would one work ...
27
votes
2answers
58k views

How can I kill a <defunct> process whose parent is init?

Transmission is intermittently hanging on my NAS. If I send SIGTERM, it doesn't disappear from the process list and a <defunct> label appears next to it. If I send a SIGKILL, it still doesn't ...
23
votes
2answers
66k views

When a process will go to 'D' state?

I'm using "Linux hostname 2.6.28-15-generic #49-Ubuntu SMP Tue Aug 18 18:40:08 UTC 2009 i686 GNU/Linux" All the client machines will use Thin-client ,I will use my laptop for working and I will ...
11
votes
4answers
93k views

How to kill a process which can't be killed without rebooting?

There are 5 processes which can't be killed by kill -9 $PID and executing cat /proc/$PID/cmdline will hang the current session. Maybe they're zombie processes. Executing ps -ef or htop will also hang ...
16
votes
2answers
44k views

Kill a process that keeps restarting

What if 'kill -9' does not work? or How to kill a script which starts new processes? doesn't help me in anyway. I have a python script which starts automatically with another process id using ...

15 30 50 per page