Linked Questions

1
vote
2answers
20k views

The repository jessie-backports Release does no longer have a Release file [duplicate]

I get the following output (and error at the end) when I run apt update on my system: $ sudo apt update Ign:1 http://deb.debian.org/debian stretch InRelease ...
3
votes
1answer
4k views

Debian apt-get update says ''Unable to find expected entry" [duplicate]

My 32 bit debian (version: Debian GNU/Linux 8) installation is suddenly giving me the following messages when I run apt-get update. W: Failed to fetch http://ftp.nl.debian.org/debian/dists/jessie-...
0
votes
2answers
429 views

Debian 8 - Can't install Git [duplicate]

I'm trying to install Git using the following commands: sudo apt-get install git-core and sudo apt-get install git Both don't seem to work. It seems that it can't find some packages. This is the ...
1
vote
0answers
540 views

W: Failed to fetch http://deb.debian.org/debian/dists/jessie-updates/main/binary-amd64/Packages 404 Not Found [IP: 151.101.140.204 80] [duplicate]

I'm trying to get a project running locally on Deepin. The project relies on node 6.10, I understand that it's an old version but it works. When the Dockerfile tries to run the sudo apt-get update, it ...
1
vote
0answers
133 views

jessie-backports fix creates “has no installation candidate” error [duplicate]

I was recently affected by the jessie-backports issue and have attempted to fix it as follows. - run: name: Apply jessie-backports Fix command: | rm /etc/apt/sources.list ...
86
votes
10answers
140k views

How to work around “Release file expired” problem on a local mirror

I have a local mirror (created with debmirror), and when I run apt-get update after a few days, I get this: E: Release file expired, ignoring file:/home/wena/.repo_bin/dists/sid/Release (invalid ...
2
votes
1answer
11k views

No public key available for the following key IDs: AA8E81B4331F7F50 [closed]

Below command: RUN apt-get update -y && \ apt-get install apt-transport-https curl python-dev python-setuptools gcc make libssl-dev -y && \ easy_install pip is giving error: ...
1
vote
2answers
7k views

Debian 8 -bash: /usr/bin/java: No such file or directory

On a new Debian system I installed JRE using sudo apt-get install default-jre Then I downloaded a jar-file and tried running it: java -jar server.jar The file threw an exception: java.lang....
1
vote
1answer
4k views

Dockerfile - debian Jessie 404: packages not found [closed]

I'm trying to set up a docker container on Debian 9.8, but I keep getting the following error when I run docker-compose up -d: W: Failed to fetch http://deb.debian.org/debian/dists/jessie-updates/...
1
vote
1answer
2k views

Debian Jessie: dpkg: unrecoverable fatal error, aborting

When i do a apt-get upgrade i get Reading package lists... Done Building dependency tree Reading state information... Done You might want to run 'apt-get -f install' to correct these. The ...
0
votes
1answer
2k views

How to install debian jessie-backports package after package removal using Docker?

The problem I'm trying to use jessie-backports in a docker repository for a Ruby on Rails project using this Dockerfile: FROM ruby:2.4.1 ENV DEBIAN_FRONTEND noninteractive ENV ...
1
vote
2answers
759 views

php curl not getting installed on Debian 8 [duplicate]

I am using linux debian 8. I have webmin/virtualmin installed and 1 domain is running over the server. Php version is 7.1. But, i can not run curl on my server. i tried to install curl but it throws ...
0
votes
1answer
67 views

How to install libdrm2-dev on Debian jessie-backports

I am using Debian 8 jessie-backports, how can I install the package libdrm2-dev? I tried apt install libdrm2-dev/jessie-backports but I get: E: Unable to locate package libdrm2-dev