Linked Questions

26
votes
2answers
81k views

Server does not accept public key for ssh login without password [duplicate]

Possible Duplicate: Why am I still getting a password prompt with ssh with public key authentication? I have ssh access to two sever. One old one and one new one. For the old one I use the ...
17
votes
3answers
36k views

Authentication refused: bad ownership or modes for file /var/git/.ssh/authorized_keys [duplicate]

EDIT The issue as exposed here is solved (about files modes of the .ssh folder. But an other issue persists so I create a new question : > Unable to login with SSH-RSA key I can no longer ...
4
votes
1answer
8k views

SSH publickey works for root but not user [duplicate]

Possible Duplicate: Why am I still getting a password prompt with ssh with public key authentication? I'm setting up a remote server. The sshd is configured to use publickey only. There are two ...
4
votes
2answers
4k views

ssh key doesn't work for one server but works for another [duplicate]

debug ssh works Authentications that can continue: publickey debug1: Next authentication method: publickey debug1: Offering public key: /home/vinatia/.ssh/id_rsa debug1: Server accepts key: pkalg ...
2
votes
5answers
3k views

Why am I still getting a password prompt with ssh with key authentication? [duplicate]

I have two Oracle Linux 7.1 servers setup (devapp and subversion are the hostnames). What I want to do is ssh into subversion from devapp without having to enter a password. I followed this guide: ...
0
votes
2answers
833 views

SSH Key not working [duplicate]

I created an SSH key on my laptop using ssh-keygen and then put it on some production servers so that I don' have to type my password every time. On some servers it is working well, but on some it's ...
3
votes
1answer
1k views

Setup SSH public key for login without password [duplicate]

Today I have setup 3 servers (4 including the server sending the SSH commands) with a public SSH key so I can automate some scripts It works on the 2 first systems but not on the third.. SSH still ...
0
votes
2answers
285 views

My ssh key doesn't work, permissions look good [duplicate]

My permissions look like this: -rw-------. 1 smpadmin staff 400 May 21 2014 id_rsa.pub -rw-r--r--. 1 smpadmin staff 505 Dec 14 19:19 known_hosts drwxr-xr-x. 45 smpadmin staff 4096 Jan ...
2
votes
1answer
486 views

ssh public key authentication fails [duplicate]

I copied my public ssh key to a remote server, but the authentication fails with the following ssh output: ilya@workstation ~ % ssh -v ilya@remoteserver OpenSSH_6.6.1, OpenSSL 1.0.1k-fips 8 Jan 2015 ...
0
votes
1answer
39 views

Same pubkey allows access on one user, but not another [duplicate]

So I have a centos 7 server with 2 users. User1 has the ~/.ssh/authorized_keys file with proper permissions and with externaluser's public key in it. User2 has the ~/.ssh/authorized_keys file with ...
0
votes
1answer
34 views

Shell script to ssh to machines. [duplicate]

Should be able to ssh from one VM to another or more other machines, but should not prompt for public key authentication. How to cover the prompt in automation using a shell script.
328
votes
10answers
799k views

How to forward X over SSH to run graphics applications remotely?

I have a machine running Ubuntu which I SSH to from my Fedora 14 machine. I want to forward X from the Ubuntu machine back to Fedora so I can run graphical programs remotely. Both machines are on a ...
8
votes
4answers
6k views

What can go wrong if we disable selinux [closed]

We inherited a bunch of used servers from another team. Some of them have SELinux enabled on it, some do not. Because of SELinux, we are having trouble setting up passwordless ssh, our webserver, ...
2
votes
5answers
12k views

Unable to login with SSH-RSA key

This post is following this question : Authentication refused: bad ownership or modes for file /var/git/.ssh/authorized_keys . The issue as exposed there is solved (about files modes of the ....
4
votes
3answers
9k views

Why can't I use public/private key authentication with ssh on Arch Linux?

I have the following setup on an Ubuntu machine: ~/dotfiles/authorized_keys2 ~/.ssh/authorized_keys2 -> /home/wayne/dotfiles/authorized_keys2 I had the same setup on my Arch machine, but when I ...

15 30 50 per page