Linked Questions

-1 votes
2 answers
5k views

Why can't read the contents of a directory? [duplicate]

All filenames mentioned here are directories. The permissions of /media/disk are 0744 (drwxr--r--). The permissions of /media/disk/directory are 0755 (drwxr-xr-x). I do not own these directories in ...
Not an artist's user avatar
0 votes
1 answer
337 views

service user unable to create/modify files in directory they own [duplicate]

I must be missing something. I created a service account that will run a script I created as a cron job. The script links files to be processed to a watched folder. The script worked fine running as ...
Robert Sicko's user avatar
2 votes
1 answer
127 views

Linux - Make logfile accessible for users without permission to the folder of the logfile? [duplicate]

My apache server puts the logfile for my project under /var/log/apache2/foo_error.log I set the user and group to the ones of my project (foo:www-data) and I even tried to chmod to 777 (i know that ...
Black's user avatar
  • 2,098
528 votes
9 answers
393k views

Execute vs Read bit. How do directory permissions in Linux work?

In my CMS, I noticed that directories need the executable bit (+x) set for the user to open them. Why is the execute permission required to read a directory, and how do directory permissions in Linux ...
Nick.h's user avatar
  • 6,373
28 votes
1 answer
38k views

In Linux, is "write" permission equivalent to "execute" for directories?

The execute permission makes sense for files (which include scripts etc.), but when it comes to directories, the write (w) permission works the same way as execute (x), right? Which means, if we are ...
its_me's user avatar
  • 14.1k
13 votes
5 answers
12k views

Directory with +x permission, parents without it. When would this be useful?

Say I have a folder called folder in the following path: my_path = /a/b/c/d/e/folder and a file called file in that folder. Then, say I run this command to remove group permissions under /a/ > ...
Amelio Vazquez-Reina's user avatar
9 votes
1 answer
15k views

Can I create a symbolic link to a file I can't access?

[Disclaimer: there's no malicious intent to this question, I'm trying to understand the ln -s command for a school project] Say I have a file system with my home folder, /home/anna. /home/bob is a ...
MyStackRunnethOver's user avatar
2 votes
4 answers
17k views

Why does httpd give an error following a symlink into my home directory on Fedora?

I've just re-enabled an app after OS change. Symbolic link to it is located of course in /var/www/myapp . After changing permissions to 0775 (even 0777 temporary), changing owner to apache:myuser, ...
Mr.TK's user avatar
  • 226
7 votes
2 answers
8k views

How do I debug filesystem permissions?

I get permission errors when I have a process running as root, spawning a subprocess as www-data, which then accesses a dir which is owned by root, with a subfolder which is owned by www-data, which ...
Jonathan's user avatar
  • 1,555
6 votes
4 answers
14k views

Noip “Can't locate configuration file”, but the file is there

I installed Noip and ran the command which created the config file /usr/local/bin/noip2 -C and then I ran the run command /usr/local/bin/noip2 and it returned Can't locate configuration file /usr/...
Will B's user avatar
  • 63
6 votes
1 answer
11k views

How to allow non root users to access root directories?

I want to secure my linux server by not permitting the root user to login. For this I've created another user with: useradd username mkdir /home/username/ mkdir /home/username/.ssh chmod 700 /home/...
Vueer's user avatar
  • 163
2 votes
3 answers
9k views

Apache2 permissions issue

I have changed my DocumentRoot to /home/user/www. To achieve that I have just changed the 2 occurrences of the path at /etc/apache2/sites-available/default. The permissions of /home/user/www are ...
barakuda28's user avatar
0 votes
2 answers
13k views

New user can't access their home

So I'm adding a new user on a machine to give a family member some remote storage. After setting up their login and home directory. Here's the stat File: `/home/heather' Size: 4096 Blocks: ...
user2085282's user avatar
6 votes
2 answers
3k views

A question about permissions of hierarchical directories

I have some directories, with following permissions: drwxr-xr-x 18 user1 root 4096 Oct 27 11:25 /home/test1/test2 drwxr-xr-x 24 user1 root 4096 Oct 21 08:38 /home/test1 drwxr-xr-x 492 root root 12288 ...
xyz's user avatar
  • 3,011
1 vote
1 answer
2k views

One folder - multiple user permission

I created folder /home/john/Desktop/test. I want to give it access to user john itself and to user mike. I created group: sudo groupadd jm And added users to same group: sudo usermod -a -G jm ...
it dev's user avatar
  • 325

15 30 50 per page