0

I'm trying since a few hours to mount a partition (md0) automatically with the server start.

The Content of my /etc/fstab:

# <file system> <mount point>   <type>  <options>       <dump>  <pass>
# / was on /dev/sdd1 during installation
UUID=369adef0-c8d7-4a35-9fcf-6e8cb6dc2546 /               ext4    errors=remount-ro 0       1
# swap was on /dev/sdd5 during installation
UUID=ed608f40-8f2f-4f57-8488-8981cc602010 none            swap    sw              0       0
/dev/sde1       /media/usb0     auto    rw,user,noauto  0       0
/dev/md0        /mnt/RAID       ext4    rw,user,noauto  0       0

But it doesn't work. Then I mount it manually via mount -t ext4 /dev/md0 /mnt/RAID, what works well. But it's very annoying to mount it manually every time the server has rebooted.

Is there a way to have this done automatically?


As it is easily confused: this is about mounting by default at startup of the system, but not about automount. The difference is that automounting mounts the filesystem automatically on access of actual files - physical read and writes - and usually unmounts when not in use.

2

You have noauto as one of the options for mounting /dev/md0. This means that the device will not be mounted implicitly (on boot, or by mount -a), but instead must be explicitly mounted.

Remove noauto, and you should get the behaviour you expect.

  • How embarrassing, but sometimes you don't see the easiest things on the first view. Anyway, thank you! It works now. :-) – SaulGoodman Nov 9 '13 at 10:55

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.