1

I bought an Asus EA-N66 that I want to use in repeater mode to extend the range of my 2.4 GHz wireless network. The setup guide allowed me to associate it to the correct SSID without a hitch, and I configured it (as per Asus' instructions) with a different SSID (but the same network passphrase) to be able to select one of the two networks depending on which one provides the best signal strength.

However, I can't seem to get Debian Wheezy to associate with the EA-N66.

iwlist scan shows it being there, along with my non-repeated wireless network. With the following in /etc/network/interfaces, the system connects to the regular wireless network:

auto wlan3
iface wlan3 inet dhcp
    wpa-psk <long hex string>
    wpa-ssid MySSID
    wpa-proto RSN

However, if I change it to the following

auto wlan3
iface wlan3 inet dhcp
    wpa-psk <same long hex string>
    wpa-ssid MyRepeaterSSID
    wpa-proto RSN

then it doesn't seem to want to associate when I do /etc/init.d/network stop followed by start (indicated by not receiving any DHCP replies). Digging around I came across a wireless security how-to on UbuntuForums, which has some specific suggestions. Based on it, instead I tried:

auto wlan3
iface wlan3 inet dhcp
    wpa-psk <still same long hex string>
    wpa-ssid MyRepeaterSSID
    wpa-proto RSN WPA
    wpa-pairwise CCIP TKIP
    wpa-group CCIP TKIP
    wpa-key-mgmt WPA-PSK
    wpa-ap-scan 1

but the system still doesn't seem to want to associate (still no DHCP replies).

What further settings do I need to change? How do I make use of the EA-N66 in repeater mode with Debian Wheezy? Preferably with a minimum of changes between the regular and the repeated networks while still able to actively pick one over the other.

Just in case it matters, the network card is an Atheros AR9287-based TP-LINK TL-WN881ND, run by the ath9k kernel module.

  • Can you connect to it using a different OS or device? Does it have some sort of MAC address filter or something? – terdon Nov 7 '13 at 16:58
  • @terdon I doubt it has MAC filtering turned on by default (that would make it rather not-easy-to-use), and as for other OS, unfrotunately the only other OS I have readily available is virtualized on the host that can't associate so it doesn't really help. – a CVn Nov 7 '13 at 17:02
  • I was just thinking of a shitty router I had once that required me to press a button to allow new devices to connect. – terdon Nov 7 '13 at 17:02
  • @terdon The EA-N66 does offer WPS, but that is primarily intended for when it is being used in "Ethernet adapter" mode (basically a wired-to-wireless converter). There's also absolutely no mention that I saw of anything like that in the web-based setup wizard. – a CVn Nov 7 '13 at 17:06
  • @terdon Network communication works great; I'm using the wireless network right now to post this comment. It's just the repeater I can't seem to associate with, so based on the fact that iwlist scan shows both, I'm guessing there's some setting somewhere that needs to be changed that I'm just forgetting about. – a CVn Nov 7 '13 at 17:09
1

The answer turned out to be really simple. The <long hex string> referenced in the wpa-psk stanza is dependent on not only the passphrase, but also the SSID. Since the SSID was different, it didn't help that the user-supplied network passphrase was identical; the PSK was still different.

Re-running wpa_passphrase with the correct SSID and using the generated WPA PSK value allowed me to establish communications through the repeater. It is now working exactly as advertised.

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.