4

Recently i've switched from mplayer to mplayer2 and there's one pestering thing: when i play an .mp3 file, and there is a picture embedded (here's an excerpt from exiftool output)

Picture Mime Type               : image/jpeg
Picture Type                    : Front Cover
Picture Description             : 
Picture                         : (Binary data 26267 bytes, use -b option to extract)

mplayer2 tries to play this picture:

Detected file format: MP2/3 (MPEG audio layer 2/3) (libavformat)
[mp3 @ 0x7f95709a9000]max_analyze_duration 5000000 reached at 5015510
[lavf] stream 0: audio (mp3), -aid 0
[lavf] stream 1: video (mjpeg), -vid 0, 
Clip info:
 album_artist: Divna Ljubojevic
 genre: Contemporary Christian
 album: Мелoди
 artist: Дивна Љубоjевић и Мелоди
 title: Аксион естин
 track: 01
 date: 2002
Load subtitles in /home/pooh/music/!CHRISTIAN/Дивна Љубоjевић и Мелоди/2002 - Мелoди/
[VO_XV] Could not grab port 63.
[VO_XV] Could not grab port 64.
[ass] auto-open
Selected video codec: MJPEG (Motion JPEG) [libavcodec]
Selected audio codec: MPEG 1.0/2.0/2.5 layers I, II, III [mpg123]
AUDIO: 44100 Hz, 2 ch, s16le, 80.0 kbit/5.67% (ratio: 10000->176400)
AO: [alsa] 48000Hz 2ch s16le (2 bytes per sample)
Starting playback...
VIDEO:  337x337  90000.000 fps    0.0 kbps ( 0.0 kB/s)
VO: [xv] 337x337 => 337x337 Planar YV12  [fs]
[ASPECT] Warning: No suitable new res found!
Colorspace details not fully supported by selected vo.
No pts value from demuxer to use for frame!
Video pts after filters MISSING

How to fight this nuisance?

Upd. The problem is not how to mask this behaviour, but rather how to make the right thing. Why in the first place it has an idea of playing embedded album picture? mplayer didn't have this… feature.

4

From man mplayer:

   -novideo
          Do not play/encode video.  In many cases this will not work, use
          -vc null -vo null instead.

Based on that statement, one (and possibly both) of the following should work:

mplayer -novideo foo.mp3
mplayer -vc null -vo null foo.mp3
  • No problems with mp3 files, but videos played with -vo null will usually show frames instead of seconds. Using -vo none instead shows progress in seconds again (just like when playing an mp3). The latter option seems to fail under some circumstances (wrong times displayed and seeking will crash mplayer) but usually it works just fine. – Tim Nov 7 '13 at 11:56
  • @Tim Thanks for the input. It should be mentioned that I am not an mplayer user (I use mpv), so I'm mostly blind here :-) – Chris Down Nov 7 '13 at 11:59
  • -novideo should be the right way to go - at least for video clips this works fine (for me). – peterph Nov 7 '13 at 12:12
  • 1
    The thing is, I use mplayer2 for playing everything. It's invoked from EMMS too. This would be a big bother — to decide how to invoke mplayer2, with or without -novideo. The question is why in the first place it has an idea of playing embedded album picture? mplayer didn't have this… feature. – aikipooh Nov 7 '13 at 13:06
  • Chris, I've tried mpv, it does the same·( – aikipooh Nov 7 '13 at 14:02

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.