I've just started using Linux Mint 15 with Cinnamon 1.8.8 at work and when I press Alt+F1 the display zoom out and displays the workspace switcher.

How can I disable this shortcut? I removed the keyboard shortcuts in System settings → Keyboard → Keyboard Shortcuts that seemed relevant but with no effect. Then I removed all of them, but of course still no effect.

Update The accepted answer worked for Mint 15. After upgrading to Mint 16 I also had to use dconf-editor as described by maosmurf below.

  • Maybe you need to log out and in again to change it effectively.
    – user13742
    Nov 7 '13 at 9:50
  • Tried to log out and back in. The Alt-F1 keybinding is still there. Nov 7 '13 at 10:00
  • You can possibly remove the keybinding by first running xev, then pressing Alt+F1, and then look at section keycode in the output. Then run the command: xmodmap -e "keycode # = """, where # is the keycode.
    – user37607
    Nov 7 '13 at 12:06

On my system (Cinnamon 1.8.8 on Linux Mint Debian Edition) I can disable it in the Gnome control center. Open a terminal and run gnome-control-center:

enter image description here

Go into keyboard => Shortcuts and select the System section on the left:

enter image description here

Now, change the shortcut for "Show the activities overview" click on it and then press Backspace to disable it.

It may be possible to do the same on Linux Mint 15 by going into cinnamon-control-center but that is not available on the Debian edition so I can't check.

  • I installed gnome-control-center with apt-get and it worked fine. Thanks! Strange that the Cinnamon settings doesn't show the "Show the activities overview" setting. Nov 13 '13 at 14:45

Under Linux Mint 16 "Petra" Cinnamon, I had a similar problem. Removing the Keyboard shortcuts under gnome-control-center and cinnamon-control-center had no effect. Solution that worked for me:

  • run dconf-editor
  • navigate to org.cinnamon.muffin.keybindings
  • for panel-main-menu, replace ['<Alt>F1'] with []
  • logout & login

(props to Nick Fortescue @ Superuser)

  • After upgrading to Mint 16, I had to do this too. Thanks. Dec 6 '13 at 7:30
  • 2
    After upgrading to Linux Mint 17.1 Rebecca, I had to remove ALT-F1 again. This time under System Settings / Keyboard / Keyboard Shortcuts / General / Toggle Expo (double click into "ALT-F1" and hit backspace) Now my IDE is happy again :)
    – maosmurf
    Feb 3 '15 at 14:10
  • Thanks so much. The Find function in dconf-editor is not capable of finding F1 in arrays o.O An alternative to switch off the shortcut is this shell command: gsettings set org.cinnamon.desktop.keybindings.wm switch-to-workspace-up '["<Ctrl><Alt>Up"]' Dec 4 '15 at 11:18
  • Thanks that worked. Had to sudo apt-get install dconf-editor first. Feb 19 '16 at 14:02
  • "double click into ... and hit backspace" wow, that is not even close to intuitive! Should be able to just select the entry and hit delete/backspace.
    – Josh M.
    Jun 14 '18 at 14:51

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.