6

I've been running byobu for a while now, and in the last few hours it has started to consume 30-100% of the CPU on the core it's running on. This a noticeable delay when entering text, or switching windows.

It does not appear to be an issue with the server (i've included the output of top below). Total memory and cpu usage appears fine, and if I open a new byobu session on the server it works fine (consuming almost 0% of the CPU).

I've never experienced this before. Any advice on what is causing it, and how to fix it without killing the whole session would be appreciated!

top - 16:09:40 up 93 days,  1:59,  4 users,  load average: 42.87, 42.77, 42.78
Tasks: 792 total,  48 running, 656 sleeping,   0 stopped,  88 zombie
Cpu(s): 38.3%us, 22.4%sy,  0.0%ni, 39.2%id,  0.0%wa,  0.0%hi,  0.0%si,  0.0%st
Mem:  528381020k total, 514696248k used, 13684772k free,    13172k buffers
Swap: 536855548k total, 114819772k used, 422035776k free,   501060k cached

  PID USER      PR  NI  VIRT  RES  SHR S %CPU %MEM    TIME+  COMMAND                                                                                                                                                                       
66004 scottr-u  20   0 88932  23m  888 S   52  0.0 270:36.19 tmux     
  • Do you see the same behaviour just running tmux? – jasonwryan Nov 6 '13 at 5:55
  • I don't even see the same behaviour if I run another byobu session. It doesn't seem like a replicable problem. – Manetheran Nov 6 '13 at 5:58
  • That makes it a very difficult problem to troubleshoot... – jasonwryan Nov 6 '13 at 6:01
  • Yeah I'm not expecting much. I didn't see anything on google, so I'm just hoping someone else has seen this before and had more insight as to what was going on. – Manetheran Nov 6 '13 at 6:06
6

It's possible that there's a runaway status script from Byobu that's consuming all of the CPU. You can perhaps disable them one by one until you find the culprit. The updates_available script is probably the most resource intensive, and the one that causes this sort of trouble most often. If you do find which one is misbehaving, please file a bug at https://bugs.launchpad.net/byobu.

Full disclosure: I am the author and maintainer of Byobu.

  • After logging back in this morning it seems to be behaving, CPU usage at <10%. If I see it happen again I'll try disabling some status notifications! – Manetheran Nov 6 '13 at 23:31
  • Wouldn't it be a good idea to find out what version of Byobu @Manetheran is running, especially since there are known bugs (like bugs.launchpad.net/ubuntu/+source/byobu/+bug/1010505 ) that can cause this issue? – Martey Nov 20 '13 at 5:59
  • Byobu version: 5.17 Tmux version: 1.6 I haven't had the issue replicate since (still the same byobu session open). – Manetheran Nov 20 '13 at 12:22

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.