0

I'm using livecd tools to build an ISO image customized to my liking. It appears to build fine, but after booting up, I get a bunch of ext4fs errors indicating referenced inodes were deleted. My custom post section copies some configuration files as well as manually installs some software.

How can I get rid of these errors?

EDIT #1

During the build process, I get these errors (I'm wondering if this may be causing the ext4 errors later on, of it is of no concern):

/etc/selinux/targeted/contexts/files/file_contexts: line 190 has invalid context system_u:object_r:nsd_conf_t:s0
/etc/selinux/targeted/contexts/files/file_contexts: line 263 has invalid context system_u:object_r:ctdbd_var_t:s0
/etc/selinux/targeted/contexts/files/file_contexts: line 389 has invalid context system_u:object_r:kdump_crash_t:s0
/etc/selinux/targeted/contexts/files/file_contexts: line 467 has invalid context system_u:object_r:condor_etc_rw_t:s0
/etc/selinux/targeted/contexts/files/file_contexts: line 609 has invalid context system_u:object_r:nsd_zone_t:s0
/etc/selinux/targeted/contexts/files/file_contexts: line 1166 has invalid context system_u:object_r:pesign_var_run_t:s0
/etc/selinux/targeted/contexts/files/file_contexts: line 1355 has invalid context system_u:object_r:nsd_zone_t:s0
/etc/selinux/targeted/contexts/files/file_contexts: line 1356 has invalid context system_u:object_r:openvpn_var_lib_t:s0
/etc/selinux/targeted/contexts/files/file_contexts: line 1375 has invalid context system_u:object_r:neutron_var_lib_t:s0

Exiting after 10 errors.

NOTE: I get these errors whether SELinux is enabled or not. I'm not sure what SELinux is blocking, if anything as I don't get any SELinux notifications that there were any problems.

Also, if I do dmesg | tail, I notice that SELinux is setup for the loopback devices for the ext4 sparse file:

SELinux: initialized (dev loop5, type ext4), uses xattr
SELinux: initialized (dev loop6, type vfat), uses genfs_contexts
SELinux: initialized (dev loop6, type hfsplus), uses genfs_contexts
SELinux: initialized (dev loop6, type hfsplus), uses genfs_contexts
  • 2
    Can you post the actual error messages? – slm Nov 5 '13 at 23:57
  • I'll have to re-run the build tomorrow. From the top of my head, the error message is deleted inode referenced. I get this while booting up to my system. Also, I'm unable to login to the system even though grepping /etc/shadow (after mounting the image) indicates the users are active and the password is set. Because I cannot login, debugging the problem is made worse. – Walter Nov 7 '13 at 0:21
  • These are the actual errors, I have built images with these errors and they work fine, provided I use selinux=0 on my kernel command line ... I'm guessing when I copy files into the chroot env, that screws up selinux. – Walter Nov 21 '13 at 1:52

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Browse other questions tagged or ask your own question.