3

I have this network adapter in an Asus notebook running Manjaro Linux (based on Arch), everything up to date (Kernel: 3.10.11):

> lspci -k | grep -A 3 -i "network"
lspci: Unable to load libkmod resources: error -12
07:00.0 Ethernet controller: Qualcomm Atheros AR242x / AR542x Wireless Network Adapter (PCI-Express) (rev 01)
    Subsystem: AzureWave AW-GE780 802.11bg Wireless Mini PCIe Card
    Kernel driver in use: ath5k

iwconfig gives:

> iwconfig
wlp7s0    IEEE 802.11bg  ESSID:off/any  
          Mode:Managed  Access Point: Not-Associated   Tx-Power=20 dBm   
          Retry  long limit:7   RTS thr:off   Fragment thr:off
          Power Management:off

I have hostapd 2.0 installed. My minimal config is:

interface=wlp7s0
driver=nl80211
hw_mode=g
ssid=test
channel=6

Running it gives

> hostapd test.conf
Configuration file: test.conf
Could not set interface wlp7s0 flags (UP): Operation not permitted
nl80211 driver initialization failed.

Running with sudo:

sudo hostapd test.conf
Configuration file: test.conf
nl80211: Failed to set interface wlp7s0 into AP mode
nl80211 driver initialization failed.

What is wrong here? How do I get my notebook to work as an AP?

7

Just found the answer myself (after googling hours to find the answer in a small but very important sentence in a private blog post about Ubuntu):

Disable (means stop the daemon or kill the process) networkmanager (or in some Distros network-manager) because it does take control over the (W)LAN Adapters, blocking it for other programs.

After doing this, hostapd can create the Access Point by initialising nl80211 correctly.

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.