2

This question already has an answer here:

I'm working in Linux. My connection to PuTTY times out very quickly and I need to have it remain active as long as I wish. I set the TMOUT in my Linux .profile but that has not seemed to make any difference.

How do I set TMOUT or whatever for PuTTY?

marked as duplicate by jasonwryan, Anthon, Bernhard, slm, rahmu Nov 4 '13 at 23:05

This question has been asked before and already has an answer. If those answers do not fully address your question, please ask a new question.

  • have you tried tcp keepalives? – Anthon Nov 4 '13 at 17:21
  • thanks anthon for a very clear and comprehensive answer. Appreciate it. – Jerry Hamilton Nov 4 '13 at 19:37
3

You need to set the keep alive settings within PuTTY to keep your session active.

            ss of putty config

There are 2 types of keepalives that you can configure. The 1st type will keep the connection alive, by simulating fake activity within the SSH session. These types of disconnections are done by the remote server when it perceives inactivity.

The 2nd type is due to a firewall that may be in between you and your remote SSH server. Again the firewall server perceives inactivity and drops your connection at the TCP level.

You'll have to determine which method is leading to your connection being dropped and then configure for it accordingly in the PuTTY configuration dialog.

References

Not the answer you're looking for? Browse other questions tagged or ask your own question.