My problem is a little weird (maybe to me only).

Specification: Lenovo, Ideapad Z510. i7 intel core. 1920x1080. ISO: GNOME Debian 7.2.0 amd64. Bootable Device: Universal USB Installer.

---Process begins---

After making the bootable USB, I, in Windows 8, go to Settings -> Change PC Settings -> Update and Recovery -> ... -> Change UEFI Settings.

In the UEFI settings, I directly make the boot method Legacy Boot with Legacy First enabled. I restart. As I expect, of course, the installation screen shows up. I hit Install, without DHCP network configured because my computer can only access a wireless network at the time. When dealing with the partitioning, I see that I have already had an ESP, so I only did two things: 1. Have a 4-GiB free space formatted to be the swap area; 2. Have a 100-GiB free space formatted to be the ex4 primary partition. Then I go on installing. The progress is fluid, and after finishing, I reboot it.

Hooray! I see both Debian and Windows 8 on the GRUB menu (I am still in Legacy Boot method).

Here come the problems:

I hit "Debian..." on the GRUB menu, and I see this: "GNOME 3 failed to load... Unfortunately GNOME 3 failed to start properly and started in the fallback mode. This most likely means your system (graphics hardware or driver) is not capable of delivering the full GNOME 3 experience... Learn more about GNOME 3". I looked up the Internet and I found something about 3D acceleration, but it doesn't apply. How do I know it doesn't? I boot the GNOME Debian live CD 64-bit in VMWare Player with 3D Acceleration turned on, but the message still pops up. So here is the first problem I have.

I hit "Windows 8" on the GRUB menu, and I see this: "Windows failed to start. A recent hardware or software change might have caused the issue...". Probably it's because I am using Legacy Boot.

--- Process stops ---

The only way to dual-boot successfully is to make Debian boot under UEFI boot method with Secure Boot turned off and Fast Boot (in Power Options in Control Panel in Windows 8) turned off. In short, what I need is that Debian will boot normally without any form of errors (like the GNOME 3 message above) with UEFI Boot turned on and Secure Boot disabled.

I first try to do this by getting in Debian. After opening a terminal with my mouse (Ctrl-Alt-T doesn't work and I haven't checked the keyboard shortcut yet.), I typed in "grub-install" but it complains "command not found"; thus I am not able to proceed. I checked the /boot directory but I didn't see the "efi" directory. I don't know why when there should be one since GRUB 2 can be for UEFI boot. By the way, during the installation I see the grub-install run without any warning or error so I am super confused right now.

I try to use EasyBCD but Debian won't boot, but saying something similar to "Windows 8 failed to start...".

I try different software for creating a bootable device including YUMI, Unetbootin, SARDU, but the problem is still not solved.

  • Don't get me wrong, but why do you need Debian? Fedora Desktop comes with Gnome 3 by default, and the packages are almost always up-to-date. It has support for EFI/UEFI too. (fedoraproject.org)
    – arielnmz
    Jun 2, 2014 at 19:05

2 Answers 2


Ok, first Linux does not yet have a great track record with EFI booting. When it works, it works quite well, but when it doesn't it's a PIA.

The most frequent issue I personally have seen is video card drivers not working in EFI mode when they work in BIOS mode. Other issues like NICs and sound cards have on occasion worked in one mode and not the other. That said. You seem to have two problems.

First, your need to boot windows in EFI mode and Linux in BIOS mode (based on your current setup). The eaisest way to do this is a project called [refind](The rEFInd Boot Manager) I have used it in the past and it works quite well.

Basically it lets you boot EFI, then choose to pass control to the windows boot loader (EFI) or Grub (BIOS).

Finally your second problem "GNOME 3 failed to load..." may be nothing more than you need to install the video drivers for your card. Try the open-source drivers first; they are quite nice these days, but keep in mind that they do not cover as much as the closed-source ones. If the open-source drivers don't work for you, revert to the proprietary drivers.

  • 1
    I guess my bet would be sticking in virtual machine for now :P Nov 3, 2013 at 20:14
  • Your really really close, you just have this one little issue to get over. And it's most certainly something that can be gotten over.
    – coteyr
    Nov 3, 2013 at 20:43
  • Do you think I can play with GRUB 2? I think GRUB 2 boots under UEFI. Nov 3, 2013 at 22:32
  • 1
    Grub2 EFI mode will work, it's just a question of "Does the video card work in Linux, via EFI?"
    – coteyr
    Nov 4, 2013 at 0:57
  • Does the Boot Manager affect the hardware compatibility of the desktop environment? Nov 4, 2013 at 2:03

Basicly, your debian is booting, you just have an issue with your video drivers. Maybe you raise a separate question for that issue.

Regaring loading Windows, you can try to use rEFInd instead of grub. (Suggestion from the arch forum). According them, you can also dowload their boot loader for an USB stick for recovery purpose.

You must log in to answer this question.

Not the answer you're looking for? Browse other questions tagged .