2

Updated 11/03: After doing some test with your suggestions, I only can be sure about one thing: there is something related to the graphical environment, because if I login through ssh or using a virtual terminal, the variable is not defined. Any new idea?

I have defined in some persistent way the http_proxy variable. Always I open a terminal, I have the http_proxy already defined.

This is not my desired behaviour, so I'm looking where I defined the http_proxy environment variable.

I'm pretty sure that is something user related, because with other users in the same computer I don't have the problem.

I have checked the .bashrc and other bash-related configuration files, but none of them include the http_proxy variable definition.

Obviously, I can unset the variable without any problem, but I want to know where the hell is the variable defined.

8
  • Have you looked under /etc/profile.d/?
    – jasonwryan
    Commented Nov 2, 2013 at 18:01
  • @jasonwryan I just looked under it, and no http_proxy definition is there Commented Nov 2, 2013 at 23:48
  • 2
    Which desktop environment do you use? If you've set up a proxy in your desktop environment, it might set this variable as well. Commented Nov 2, 2013 at 23:50
  • @Gilles I'm using Gnome 3, in Debian Unstable. I have checked in the network configuration dialogs and the proxy is not configured. Maybe a value in gsettings/dconf can assign a environment variable? Commented Nov 3, 2013 at 0:04
  • 1
    Hi! Finally I just figured what the problem is: when the change from gconf to dconf happened on Debian's Gnome version, I had the http_proxy configured. I don't have the proxy configued into my Gnome configuration (now, under dconf system), but I had it under gconf. One of scripts run when the user session is opened is a program to import gconf properties to the session. So, the proxy is not shown in my Gnome configuration but it is applied to the environment variables. I remove the values from gconf system and I forget about the problem. Thanks for point me in the right direction Commented Nov 4, 2013 at 22:48

4 Answers 4

1

Yuo could try a grep in your home directory or in etc. Something like:

 $ cd ~ 
~$ grep -Ri http_proxy *
4
  • 2
    Please no signatures on posts.
    – goldilocks
    Commented Nov 2, 2013 at 15:27
  • I tried something very similar: find $HOME -type f | xargs grep -i http_proxy, and it doesn't return anything Commented Nov 2, 2013 at 17:08
  • @JoseLSegura Do the same thing with /etc in addition to $HOME. Commented Nov 2, 2013 at 23:49
  • @Gilles I have tried with both $HOME and /etc, and looking for http_proxy (with -i grep option, to ignore case) and for the defined value for the variable. Returns nothing in the 4 scenarios. This is the reason because I'm here asking this :-D Estrange thing... Commented Nov 3, 2013 at 0:03
0

The environment variables are saved in /etc/environment

cat /etc/environment | grep "http_proxy"

And proxy for aptitude are save in /etc/apt/apt.conf

cat /etc/apt/apt.conf | grep "http::proxy"
3
  • The http_proxy is defined for all the environment, not only for APT (for example, with wget it tried to use the defined proxy). My /etc/environment file is empty. Nice try Commented Nov 2, 2013 at 16:43
  • How you defined the http_proxy?
    – andr3w
    Commented Nov 2, 2013 at 17:13
  • I don't remember, that's the problem :-D Commented Nov 2, 2013 at 17:15
0

I don't know if this question already has an answer, but this is my /etc/environment:

PATH="/usr/local/sbin:/usr/local/bin:/usr/sbin:/usr/bin:/sbin:/bin:/usr/games:/usr/local/games"
http_proxy="http://192.168.0.1:8080"
ftp_proxy="ftp://192.168.0.1:8080"
https_proxy="https://192.168.0.1:8080"
export http_proxy ftp_proxy https_proxy
0

I was facing similar problem (after using Fiddler proxy to debug some stuff - I guess that was the source of problems).

Clearing out gconf dir:

rm ~/gconf/system/proxy -R
rm ~/gconf/system/http_proxy -R

And relogging did the trick.

You must log in to answer this question.

Not the answer you're looking for? Browse other questions tagged .