4

I just installed Debian Wheezy stable. I am now facing the problem, that I am not able to activate the WiFi. I use a HP-Pavilion DM1 notebook with a button (F12 and wlan button) to activate the WiFi. However pressing it does not cause any reaction.

Furthermore ifconfig -a does not list wlan0. The computer is equipped with a Broadcom BCM4313 Wireless LAN controller, so I installed the firmware-brcm80211 driver. As a network manager I installed WICD since I use the XFCE desktop.

Does anybody have a clue what is going on?

1

I found a solution for my problem. I tested different drivers that were mentioned for the Broadcom Chip. The first success was a slow wifi connection. The thing is to have a look that sometimes more than one driver module can be disturbing for the driver. Driver modules can be unloaded with modprobe -r followed by the module name. They can be loaded by the same command without the -r.

Still the connection was slow. I found the solution on this debian wiki page. The driver described here is the vendor driver wl from Broadcom.

This one is seen skeptical by the debian community because it is not open-source and seems to cause problems sometimes. However it works good for me so far.

What I did was (as superuser):

$ apt-get update 
$ apt-get install linux-headers-$(uname -r|sed 's,[^-]*-[^-]*-,,') broadcom-sta-dkms
$ modprobe -r b44 b43 b43legacy ssb brcmsmac   #That's where 5 unneeded modules are unloaded...
$ modprobe wl   #...and the right one is loaded this way

Note that non-free repositories need to be enabled. For more info see provided link (above).

Edit:

If anybody has the same issue: Be careful! I don't know if this is related to the previous problem, but one day later I try to boot the laptop and booting doesn't work anymore. I just get something that seems to be a kernel panic error. Maybe the two problems are not related, but who knows! Maybe this is one of the problems of the wl module why the debian community hates proprietary drivers.

Edit 2:

The two problems are definitely related. A possible solution can be found on this page. In summary the proposed solution is:

  1. Make sure the interfering modules are blacklisted at /etc/modprobe.d/broadcom-sta-dkms.conf
  2. Add hp_wmi, lib80211 and lib80211_crypt_tkip to the initramfs by writing them into /etc/initramfs-tools/modules.

This works for me, I guess. No problem since nearly one week!

Update 24.03.2014: Still no problems

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.