2

I am trying to install Charm crypto python framework in ubuntu 11.04 with python 2.7. Requirements say that i should have gmp installed 5.*. I have successfully installed gmp lib and i have run all the tests. Also after running `

ldconfig -p |grep libgmp

libgmpxx.so.4 (libc6,x86-64) => /usr/lib/libgmpxx.so.4
libgmpxx.so (libc6,x86-64) => /usr/lib/libgmpxx.so
libgmp.so.10 (libc6,x86-64) => /usr/local/lib/libgmp.so.10
libgmp.so.3 (libc6,x86-64) => /usr/lib/libgmp.so.3
libgmp.so (libc6,x86-64) => /usr/local/lib/libgmp.so
libgmp.so (libc6,x86-64) => /usr/lib/libgmp.so

In order to install Charm i have downloaded it from here. I run ./configure, make , make install, and sdconfig as the INSTALL says.

But after running make test for i am getting a lot of errors of this form:

charm/Charm-Crypto-0.43/charm/core/math/integer.so: undefined symbol: __gmpz_powm_sec

Charm shared libraries cannot find libgmp. How can i fix that? I made an ldd integer.so and it uses libgmp.so.3. In my system libgmp.so.3 is placed under /usr/lib so added this line under te config.mk file of the Charm framework:

LDFLAGS= -m64 -L/usr/lib . 

(-m64 was already there). I make and make install again but i am getting the same error

2 Answers 2

2

It might be just you didn't install the dev lib for gmp, try:

sudo apt-get install libgmp-dev

Then re-do configure/make/etc. for Charm

4
  • I have already installed it. The correct name is libgmp3-dev
    – curious
    Commented Oct 31, 2013 at 8:23
  • @curious Charm required libgmp 5, libgmp3-dev is only for libgmp 3
    – number5
    Commented Oct 31, 2013 at 11:42
  • but making an ldd to integer.so that causes most of the problems i see that it is linked ton libgmp3.so : ldd integer.so linux-vdso.so.1 => (0x00007fff347ff000) libgmp.so.3 => /usr/lib/libgmp.so.3 (0x00007fd4b9014000) libcrypto.so.0.9.8 => /lib/libcrypto.so.0.9.8 (0x00007fd4b8c85000) libpthread.so.0 => /lib/x86_64-linux-gnu/libpthread.so.0 (0x00007fd4b8a66000) libc.so.6 => /lib/x86_64-linux-gnu/libc.so.6 (0x00007fd4b86ce000) libdl.so.2 => /lib/x86_64-linux-gnu/libdl.so.2 (0x00007fd4b84ca000) libz.so.1 => /lib/x86_64-linux-gnu/libz.so.1
    – curious
    Commented Oct 31, 2013 at 11:45
  • also there is no libgmp5-dev package
    – curious
    Commented Oct 31, 2013 at 11:45
0

I was also facing the same issue while building mpfr. My libgmp.so was in /usr/local/lib. Running the folowing command solved the issue:

sudo ldconfig -n /usr/local/lib

Alternatively you can edit /etc/ld.so.conf and add lib dir path here or just copy all files from /usr/local/lib to /usr/lib.

You must log in to answer this question.

Not the answer you're looking for? Browse other questions tagged .