I'm trying to install wine on my computer without root access. I know to change the prefix using automake --prefix=$HOME/Self_Programs but then I get this error message:

[tomas@wizard wine-1.1.27]$ automake --prefix=$HOME/Self_Programs`
automake: unrecognized option '--prefix=/home/tomas/Self_Programs'.`
automake: Try '/usr/bin/automake --help' for more information.`

(This was tried before and after using the configure command in the source code)

I'm really stuck here: can someone help as to what I'm doing wrong?

  • What distro are you using?
    – slm
    Oct 31 '13 at 2:20
  • @slm Umm CentOS 6
    – Xanpheon
    Oct 31 '13 at 8:30

With a GNU autotools build system, you pass the --prefix option to the configure script. The following should work for compiling wine:

./configure --prefix=$HOME/Self_Programs
make install
  • I tried that and it didn't work for some reason. Its made everything it needs in Self_Programs but still hasn't installed.
    – Xanpheon
    Oct 31 '13 at 8:49

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.