(I just switched from Gnome 2 to Xfce 4, so I have still to find my way around how Xfce works.)

Iceweasel is opened on Workspace 1, Icedove is opened on Workspace 2. I click at a link in Icedove, which opens a tab in Iceweasel. Great, but: Iceweasel moves to Workspace 2 and gets focus.

Can I configure it so that windows always stay on their workspace, no matter if other application interact with them? And that the focus doesn’t get changed?

On Gnome 2, Iceweasel stayed on Workspace 1, but it was highlighted/blinking in the taskbar of Workspace 2 (instead of being focused). I’d like to have that (or a similar) behaviour in Xfce, too.

1 Answer 1


The setting you're looking for is listed under "Window manager tweaks".

  1. XFCE menu
  2. Settings
  3. Window Manager Tweaks
  4. Focus
  5. "When a window raises itself"
  6. "Do nothing"

Window manager tweaks

Note that you cannot get the behavior where it will show raised windows on other workspaces. You can have it show all windows on all workspaces, or the current workspace. There's no option for "only this workspace plus raised windows on other workspaces".

  • 1
    I totally overlooked this setting. Thank you, Patrick. This solves my main concern (the only thing missing now is an indication that the link actually got opened; but, as you explained, there doesn‘t seem to be a way.)
    – unor
    Nov 1, 2013 at 14:29
  • 1
    Thank you so much! Years later and still a useful answer. No more moving browsers back to their workspaces :) Oct 31, 2019 at 21:17
  • This has helped me not lose my g******n mind in xfce using workspaces.
    – SeedyROM
    Jan 14, 2021 at 8:50
  • That should be the default behavior.
    – user51872
    Jan 27, 2022 at 21:24

You must log in to answer this question.

Not the answer you're looking for? Browse other questions tagged .