0

I am mounting a git repository on a virtual machine over sshfs onto my host machine. So far so good. However, git claims that there are many uncommitted changes when viewing the repository over sshfs.

Why is that?

The relevant bit from /etc/fstab, if that helps:

sshfs#usr@virtual:/home/user/repos /home/user/repos/ fuse noauto,user,uid=1000,gid=1000,umask=0,workaround=rename 0 0

Note: Cloning, push, and pull operations could done instead but the code needs to compile on the virtual machine OS and not on the host machine -- long story, it has to be this way. I do not fancy doing a commit per compile, that's just silly.

1

It seems like both FUSE and sshfs will change inodes out from under you. A quick Google search suggests adding -o workaround=rename (sshfs) and -o noforget (FUSE) to your mount options.

|improve this answer|||||
  • +1 for the explanation of why it does not work. However, neither options as added to /etc/fstab makes a difference. – Sardathrion - against SE abuse Oct 27 '13 at 10:19

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.