I bought a new PC with Windows 8 and wanted to dual-boot linux.

I shrank the partition by 50GB in windows, then installed CentOS from a live CD.

CentOS is working fine, but I can't boot into Windows 8 any more.

My Grub options are CentOS and "other" -- when I select "other" it basically says windows cannot boot properly.

I don't believe anything has been overwritten on the Windows 8 partition, but the boot sequence is out of whack.

How should I go about troubleshooting this?

[root@localhost]# parted -l
Model: ATA ST500DM002-1BD14 (scsi)
Disk /dev/sda: 500GB
Sector size (logical/physical): 512B/4096B
Partition Table: gpt

Number  Start   End     Size    File system  Name                          Flags
 1      1049kB  525MB   524MB   fat32        EFI system partition          boot
 2      525MB   567MB   41.9MB  fat32        Basic data partition          hidden
 3      567MB   701MB   134MB                Microsoft reserved partition  msftres
 4      701MB   1215MB  514MB   ntfs         Basic data partition          hidden, diag
 5      1215MB  436GB   435GB   ntfs         Basic data partition
 7      436GB   437GB   524MB   ext4                                       boot
 8      437GB   488GB   51.0GB                                             lvm
 6      488GB   500GB   12.6GB  ntfs         Microsoft recovery partition  hidden, diag

Model: Linux device-mapper (linear) (dm)
Disk /dev/mapper/vg_centos6-lv_swap: 4027MB
Sector size (logical/physical): 512B/4096B
Partition Table: loop

Number  Start  End     Size    File system     Flags
 1      0.00B  4027MB  4027MB  linux-swap(v1)

Model: Linux device-mapper (linear) (dm)
Disk /dev/mapper/vg_centos6-lv_root: 47.0GB
Sector size (logical/physical): 512B/4096B
Partition Table: loop

Number  Start  End     Size    File system  Flags
 1      0.00B  47.0GB  47.0GB  ext4


Use os-prober. If it's not installed then install it. Then run grub-mkconfig -o /boot/grub/grub.cfg.

UEFI secure boot

After some additional digging it appears that Pre install windows 8 comes with UEFI secure boot enabled (UEFI which substitutes what we have known as the BIOS) which prevent unrecognized source to boot or Linux

You can off the UEFI secure boot if you want:

  1. while holding shift key click on restart option (from power)
  2. windows will show you option then select Troubleshoot
  3. select advanced options
  4. select UEFI frameware settings then disable it after restart

If you don’t get the windows 8 listed in grub menu then type following command in terminal while mounting drive which have windows installed

grub2-mkconfig -o /boot/grub2/grub.cfg
  • Is os-prober available on centos? It looks debian specific..
    – some1
    Oct 24 '13 at 22:03
  • os-prober is universal but it appears that some distros don't offer it with their official repositories. You may need to find an rpm.
    – Jeight
    Oct 24 '13 at 22:12
  • os-prober is an RPM on Fedora, not in the default repos of CentOS 6.
    – slm
    Oct 24 '13 at 22:19

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.