3

My local partitions are detected as multipath device

$multipath -l

mpathb (360014380125d90420000a000003e0000) dm-9 HP,HSV450
size=200G features='1 queue_if_no_path' hwhandler='0' wp=rw
`-+- policy='round-robin 0' prio=0 status=active
`- 3:0:0:1 sdb 8:16 active undef running
mpatha (3600508b1001c02143bc59c6862d97353) dm-0 HP,LOGICAL VOLUME
size=137G features='1 queue_if_no_path' hwhandler='0' wp=rw
`-+- policy='round-robin 0' prio=0 status=active
`- 0:0:0:1 sda 8:0  active undef running

I added the following lines in multipath.conf so that local partitions are not detected as multipath device

blacklist {
   wwid 3600508b1001c02143bc59c6862d97353
}

Executed the following commands after that .

#service multipathd reload

# multipath -F
Oct 22 12:10:42 | mpathb: map in use
Oct 22 12:10:42 | mpatha: map in use

Is reboot of the server will resolve the issue ? It is a production server , so I have to take downtime before going ahead with reboot.

2 Answers 2

3

I resolved the issue . Apart from blacklisting the device in multipath.conf , we had to recompile the RAMDISK so that during booting local disk is blacklisted . Simple excluding the disk and rebooting the server did not helped me to resolve the issue .

Steps are as follows:

Step 1.Blacklist local disk in /etc/multipath.conf by using WWID of the device

blacklist {
wwid 3600508b1001c02143bc59c6862d97353
}

Step 2.Create RAMDISK

1. cp  /boot/initramfs-<>.img /root/

2. mkinitrd -f /boot/initramfs-`uname -r`.img `uname -r`

Step 3. Reboot server and verify using multipath command

$multipath -l 

mpathb (360014380125d90420000a000003e0000) dm-9 HP,HSV450
 size=200G features='1 queue_if_no_path' hwhandler='0' wp=rw
`-+- policy='round-robin 0' prio=0 status=active
`- 3:0:0:1 sdb 8:16 active undef running

More of the issue is detailed here
http://yenonn.blogspot.in/2013/05/linux-dm-multipath-on-local-disk.html

0

Obviously, disabling the multipath device by issuing multipath -f mapth_device or mmultipath -F doesn't work for you.

In such case, if the message map in use appears for a device when you attempt to disable multipathing, the device is still in use. You must unmount or otherwise quiesce the device before you can disable multipathing.

If you cannot quiesce the device, edit the /etc/multipath.conf file to exclude the device and then reboot the server.

1
  • Tried rebooting the server by excluding the device by adding a blacklist entry for the device in multipath.conf as shown in original query but no luck . Am I missing anything ?
    – Zama Ques
    Commented Oct 22, 2013 at 9:40

You must log in to answer this question.

Not the answer you're looking for? Browse other questions tagged .