3

I have 500GB disk in my toshiba laptop, I tried to do backup of files in this HDD but it failed few times (ubuntu just closed copying operation or unmounted disk during copying files).

So I boot my laptop from ubuntu 12.10 on USB, and I didn't mount that harddrive (it's /dev/sda1) and I run:

sudo badblocks -nvs /dev/sda1

and output is:

[3277.882968] end_request: I/O error, dev sda, sector 825437

and milion of similar lines but with different numbers

Should I mount this disk before I run badblocks? Why it's returning so many I/O errors? Do you know other applications to check disk? I still can mount this disk and browse files on in, but it looks like I have bad sectors or something is wrong with this HDD, so I'd like to check it.

3
  • 4
    Those type of errors point to a physical disk or controller problem. You are on the brink of losing data if you haven't already. Grab a clonezilla liveCD and new disk and clone that thing with the "rescue" option ASAP.
    – Tim
    Oct 21, 2013 at 16:38
  • Any relevant clues from this post on AskUbuntu? Jun 16, 2018 at 22:45
  • Thank you @XavierStuvw for your answer. I asked that question 5 years ago so I don't remember how did I recover data from that laptop, but probably I used clonezilla. I didn't think about circuits dusting at that time, but thank you for this tip, I'll try it next time with old HDD :)
    – marcinpl87
    Jun 18, 2018 at 8:47

0

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Browse other questions tagged or ask your own question.