I would like to leave EPEL enabled and configure it to allow updating only the packages that were installed from EPEL itself in the first place (packages which were manually installed from EPEL because of specific needs). Is there a yum conf directive to allow this?

  • CentOS 6.4
  • Yum 3.2.29
  • It should just work like this since EPEL packages never include packages that are in base.
    – jordanm
    Oct 21, 2013 at 16:00
  • However, EPEL can conflict with local and other third-party repos, such as ATrpms, RPMforge, or other vendor-specific repos. Oct 21, 2013 at 19:09
  • Yes, @JamesSneeringer: in my case, Virtualmin
    – Gaia
    Oct 21, 2013 at 19:09

1 Answer 1


Install the yum-plugin-priorities package, which lets you add a priority parameter to your repo files. The priority range is 1-99, with 99 being the default. A lower number means higher priority.

Since 99 is the default, and you want to give EPEL even less priority, you'll need to increase the priority (lower number) of all other repos to ensure EPEL doesn't override them. For example:




I'm doing exactly this to ensure my local repo gets priority, and it works great.

  • This does not work for me. I have package XYZ which is v0.44 and was installed from ART. If EPEL is enabled, 'yum upgrade' will offer to update XYZ with v0.48 from EPEL. ART is priority=1 and EPEL is priority=99.
    – Gaia
    Oct 21, 2013 at 19:22
  • Is the priorities plug-in enabled? It should be by default, but you can double-check in /etc/yum/pluginconf.d/priorities.conf. There should be a line that says enabled=1. Oct 21, 2013 at 19:53
  • it wasn't, thanks. but now I have "77 packages excluded due to repository priority protections". how do i find out which ones were excluded? before enabling it i had nothing to upgrade.
    – Gaia
    Oct 21, 2013 at 20:08
  • Run yum with debug level 3 (-d 3). The default appears to be level 2, which only shows the summary. At level 3, it will show which packages were excluded, and from which repo(s). Oct 21, 2013 at 21:42

You must log in to answer this question.

Not the answer you're looking for? Browse other questions tagged .