1

I'm on a Debian distro, it's been a long time that I edited Openbox menu.xml, so I forgotten that I had to use obmenu or whatever, I opened it in a normal text editor, edited something in the right-click menu. Then saved then restarted Openbox without reconfiguring it.

And now I can still login, after that all I see is a black screen with the mouse cursor. I tried opening the terminal using the Super key + T keyboard combination, but I can't see anything at all, no terminal, no web browser, just a cursor and a black screen.

Note, I can't boot to a live CD, due to a nomodeset issue. If nomodeset is on, my PC won't boot correctly, so I always set it to off, but when booting from a live CD, you can't set it to off.

  • 2
    Ctrl-Alt-F2 to get into a tty. Login. Use nano or your preferred console text editor to fix your configuration. – strugee Oct 18 '13 at 23:13
  • @strugee just tried that, well i go to a black window and all i see is a white - sign, i typed nothing happens, i don't see text on the screen, just -, that's all i see – Lynob Oct 18 '13 at 23:34
  • 1
    I would try Ctrl-Alt-F3 then. if not, reboot your computer. if you still can't get it to work, and don't have another desktop environment installed, you're just about screwed without a live cd. – strugee Oct 19 '13 at 0:04
  • i tried everything from f1 to f11, f7 doesn't enter tty, it exits them on my pc, other keystrokes gave me a black screen and i rebooted many times.... i have windows 7 installed and could do a third linux partition, fix it from there and then delete it, if that an option – Lynob Oct 19 '13 at 0:23
  • you're screwed without a Live CD. and there's no possible way that you can't set kernel parameters when you boot a Live CD. I suspect you just haven't poked around enough. anyway, your symptoms are much more serious than a mere Openbox issue. I don't know enough to help you fix it, but for when you Google for your problem, your symptom is that getty isn't run on any of your consoles on Debian. good luck. – strugee Oct 19 '13 at 5:26
4

Use Ctrl-Alt-F2 - F5 to bring up a tty login. After logging in you can open you menu.xml file with a text editor and fix the problem. Once finished run the update-menus command and then reboot the computer or kill the Openbox session.

Instead of restarting or killing the session, you might get lucky with the openbox --reconfigure command. Then just Ctrl-Alt-F7 (or whatever tty your GUI is on).

  • please read my comment above sir – Lynob Oct 18 '13 at 23:35
  • I did, but I don't see anywhere there that you've tried update-menus or openbox --reconfigure. – Jeight Oct 18 '13 at 23:53
  • that's because i don't see anything, the letters i type aren't showing on the screen so i can't edit the file – Lynob Oct 18 '13 at 23:59
  • 2
    And Ctrl-Alt-F3, Ctrl-Alt-F4,Ctrl-Alt-F5 do the same thing? Openbox's menu.xml or X-Display shouldn't have any effect on other ttys. – Jeight Oct 19 '13 at 0:01
  • please read my comment above, i tried everything – Lynob Oct 19 '13 at 0:24

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.