1

I am running Solaris 11 on VMWare Workstation host machine Windows 7. Here is my OS and system details: SunOS solaris 5.11 11.0 i86pc i386 i86pc

I want to boot Solaris 11 in text mode only i.e make it persistently boot in text mode and not boot into GUI. I tried editing menu.lst. My menu.lst is as follows:

default 0
timeout 30
splashimage /boot/grub/splash.xpm.gz
foreground 343434
background F7FBFF
title Oracle Solaris 11 11/11
bootfs rpool/ROOT/solaris
kernel$ /platform/i86pc/kernel/amd64/unix -B $ZFS-BOOTFS,console=text
module$ /platform/i86pc/amd64/boot_archive
title solaris-backup-1
bootfs rpool/ROOT/solaris-backup-1
kernel$ /platform/i86pc/kernel/amd64/unix -B $ZFS-BOOTFS,console=text
module$ /platform/i86pc/amd64/boot_archive

My problem is that when I reboot Solaris 11 it initially shows up with a command line login asking for username, but as I'm typing the username in, it just boots into GUI anyway showing up a GUI login screen. How can I make Solaris persistently boot into text mode. I have tried boot time grub parameter editing and that way doesn't work either.

3 Answers 3

4

svcadm disable gdm to stop the login GUI service from running automatically on boot.

0

This has nothing to do with booting OS as you stated that when you try to login there's X11 starting. This is post-boot scenario. I'm not Solaris expert but if it uses runlevels then you have to change runlevel not to start X11 (gdm, xdm, whatever). If it does not have separate runlevel for X11 mode, then you have to disable X11 (gdm, xdm...) to start after boot.

1
  • You are correct. I have mainly used CentOS previously and only had to change runlevel in /etc/inittab, but found Solaris's /etc/inittab a little different. That's why I was confused. Will research more on it though.
    – mk_gunner
    Commented Oct 18, 2013 at 9:26
0

I just found a solutions. It was a pain in the ass, but I got there.

It was a combination of GRUB settings and disabling GDM.

  1. In GRUB, changed from console graphic to console text.

    # bootadm list-menu
    The location of the boot loader configuration files is: /rpool/boot/grub
    default 3
    console text
    timeout 30
    0 Oracle Solaris 11.4
    1 solaris-1
    2 11.4.27.82.1
    3 11.4.28.82.3
    
  2. Then I had to remove kargs in the GRUB entry.

    root@fmsops:# bootadm show-entry -i 4
    title: 11.4.27.82.1
    kernel: /platform/i86pc/kernel/amd64/unix
    kernel arguments: None
    boot archive: /platform/i86pc/amd64/boot_archive
    bootfs: rpool/ROOT/11.4.27.82.1
    

    That took care of bootup, but it still tried to get me to the GUI at login.

  3. I had to disable GDM.

    # svcs -a | grep gdm
    online         11:21:59        svc:/application/graphical-login/gdm:default
    # svcadm disable svc:/application/graphical-login/gdm:default
    

You must log in to answer this question.

Not the answer you're looking for? Browse other questions tagged .