I am trying to understand the disk usage in my RHEL system. When I run the Disk Usage Analyzer tool graphically, my screen shows the below output.

enter image description here

However, if I run the command df -h I get the below output.

Filesystem            Size  Used Avail Use% Mounted on
/dev/sda5              38G   23G   14G  64% /
/dev/sda7             146G   48G   91G  35% /home
/dev/sda3              99M   23M   72M  24% /boot
tmpfs                 2.0G     0  2.0G   0% /dev/shm

In the graphical output, I see the / is having 71.7 GB and usage is 100%. However, from the command line, I see that I still have 14G left and the use % is only 64. Why is there a discrepancy between the command line and the graphical output?

How can I interpret the output?


That's because the GUI tool (I think that's baobab) does not take into account the different partitions, it only looks at the directory tree. This means that it sees /home as a subdirectory of / but does not consider that it is a separate partition.

If you look at your df output:

/dev/sda5              38G   23G   14G  64% /<br>
/dev/sda7             146G   48G   91G  35% /home

you have 23G used in / and 48G used in /home. 48+23=71 so baobab is reporting 71G used in /.

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.