18

I'm running Fedora 19 (GNOME Shell 3.8.4). I have a dual monitor setup (two 1440 x 900), and I want to be able to stretch my wallpaper over the two monitors, like I was used to when using Ubuntu 12.04.

I don't want different wallpapers for each workspace, nor different wallpapers for each monitor (that would be pretty cool, but falls out of scope of the question). What I want is a 2880 x 900 (or any 3.2:1 proportional image) to be shown half on one monitor, and half on the other:

enter image description here

How I had set it on Ubuntu

If I boot with my 12.04 LiveUSB, it starts in "mirror displays" mode. I have to disable display mirroring (enable extended monitors) in order to have different images on each screen:

enter image description here

Then, I open the System Settings and on the Appearance section I can choose the background, and have several options. Chosing "span" (see the dialog on first image rightmost side) will have the background like I want it to be.

How I (don't) have it on Fedora

The System Setting screen doesn't have an "Appearance" icon, just a "Background" one, with no options at all. If I choose an image, it will be applied to each monitor repeatedly, like this:

enter image description here

25

I have no idea why the configuration option is not available in the gnome control panel but you can set this using dconf-editor.

Run dconf-editor from a terminal, navigate to org.gnome.desktop.background -> picture options and set it to spanned:

enter image description here

  • In addition to changing this for the wallpaper, you can also change it for the lock screen: dconf-editor -> /org/gnome/desktop/screensaver/picture-options = 'spanned' – Jonathan Nicol Jan 16 '14 at 19:05
8

Installing gnome-tweak-tool lets you customize not only the wallpaper alignment, but other absent options such as enabling / disabling minimize and maximize buttons, showing icons on the desktop, changing the shell theme and colors, changing fonts and its options (size, hinting, etc).

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.