5

On Ubuntu 10.04 I experience choppy video playback.

I am running Mplayer and have an Nvidia GeForce 9800 GTX+ video card. I have already installed the libvdpau1 library. I don't know if hardware acceleration is enabled on my video card or if it is supported.

Can anyone provide suggestions on how to decrease the choppiness?

Here is my xorg.conf file:

# nvidia-settings: X configuration file generated by nvidia-settings
# nvidia-settings:  version 1.0  (buildd@yellow)  Fri Apr  9 11:51:21 UTC 2010

Section "ServerLayout"
    Identifier     "Layout0"
    Screen      0  "Screen0" 0 0
    InputDevice    "Keyboard0" "CoreKeyboard"
    InputDevice    "Mouse0" "CorePointer"
    Option         "Xinerama" "0"
EndSection

Section "Files"
EndSection

Section "InputDevice"
    # generated from default
    Identifier     "Mouse0"
    Driver         "mouse"
    Option         "Protocol" "auto"
    Option         "Device" "/dev/psaux"
    Option         "Emulate3Buttons" "no"
    Option         "ZAxisMapping" "4 5"
EndSection

Section "InputDevice"
    # generated from default
    Identifier     "Keyboard0"
    Driver         "kbd"
EndSection

Section "Monitor"
    # HorizSync source: edid, VertRefresh source: edid
    Identifier     "Monitor0"
    VendorName     "Unknown"
    ModelName      "ACI ASUS VH236H"
    HorizSync       30.0 - 85.0
    VertRefresh     55.0 - 75.0
    Option         "DPMS"
EndSection

Section "Device"
    Identifier     "Device0"
    Driver         "nvidia"
    VendorName     "NVIDIA Corporation"
    BoardName      "GeForce 9800 GTX+"
EndSection

Section "Screen"
    Identifier     "Screen0"
    Device         "Device0"
    Monitor        "Monitor0"
    DefaultDepth    24
    Option         "TwinView" "1"
    Option         "TwinViewXineramaInfoOrder" "DFP-0"
    Option         "metamodes" "DFP-0: nvidia-auto-select +1920+0, DFP-1: nvidia-auto-select +0+0"
    SubSection     "Display"
        Depth       24
    EndSubSection
EndSection
3
  • curious why do you have an xorg.conf? most of the time these days xorg auto detects everything? I speculate that even if you need one for something things you could leave a lot of stuff out like the kbd and mouse sections. Aug 21, 2010 at 19:06
  • The xorg.conf file is still configured and used in Ubuntu 10.04 even though its all done through a gui. Aug 21, 2010 at 19:42
  • This really belongs on ubuntu.stackexchange.com, not here.
    – clee
    Aug 24, 2010 at 10:06

4 Answers 4

3

The reason you have an xorg.conf with all those settings is that you use the proprietary nvidia driver and the GUI tools that come with it; my Intel & ATI graphics (with open source drivers) don't need any xorg.conf settings anymore.

Now, about the choppiness:

  1. what sort of video are you trying to play (resolution, codec, ...)?
  2. does mplayer actually use vdpau? (I'm pretty sure it will say that somewhere in the output you get when you start it in a terminal.)
  3. is your PC doing other things at the time you try to play this?
  4. are you playing this from a local drive or over a network? (wired/wireless?)
2
  • Are we even sure that the proprietary nVidia drivers are installed, what framerate do you get when you run glxgears, a really low one ( less than 1000 ) indicates that they are not installed correctly. If they are installed does the card support hardware accelerated video? Some higher end gaming cards from that time period do not, despite impressive 3d performance.
    – Sqeaky
    Aug 22, 2010 at 20:39
  • @Sqeaky: his xorg.conf is hardcoded to work with the binary driver: ` Driver "nvidia"`
    – JanC
    Aug 23, 2010 at 5:45
0

Are you sure your mplayer is configured with vdpau support? If unsure, add this ppa to your sources and install the mplayer package: ppa:rvm/mplayer

To make sure you're using VDPAU, try this (assuming ALSA sound here, YMMV):

mplayer -ao alsa -vo vdpau -vc ffmpeg12vdpau,ffh264vdpau,ffwmv3vdpau,ffvc1vdpau,ffodivx, foo.avi

VDPAU uses hardware-accelerated playback, so the CPU shouldn't be really busy while playing a video file.

0

I ran into this issue on an older laptop running Lubuntu. My problem appears to be the result of missing codecs. I was able to install them by running the following commands in the terminal and rebooting. Note that you will need to accept the TOS.

sudo add-apt-repository multiverse
sudo apt install ubuntu-restricted-extras
-1

Still a problem in Linux Mint 16.... This has been driving me nuts for some time. Finally found the solution:

Dump cinnamon/gnome/mate:

1/ apt-get install xfce4

2/ at the login select xfce instead of cinnamon or mate. Voila! video is no longer choppy. (You can always log out and log in with cinnamon if you don't like xfce.)

Something to do with cinnamon/gnome running on 1 thread maybe.

To clarify this fixes the video jerking twice a second on everything from SD to HD videos graphics acceleration or not etc.

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.