I have disabled slim and lightdm, using startx instead. Almost everything works, except I cannot control the network connections with NetworkManager when logged in as the non-root user. Enable Networking and Enable Wifi are grayed out. If I go to Edit Connections and select either connection, the Edit button is grayed out. I have tested using the root user, which does work.

I wrote a polkit rule that is supposed to resolve this, but it does not. I created file /etc/polkit-1/rules.d/50-org.freedesktop.NetworkManager.rules containing:

polkit.addRule(function(action, subject) {
  if (action.id.indexOf("org.freedesktop.NetworkManager.") == 0 && subject.isInGroup("netdev")) {
    return polkit.Result.YES;

My userid is a member of group netdev. My system is Debian Sid and my DE is LXDE. My ~/.xinitrc contains:

exec ck-launch-session dbus-launch /usr/bin/startlxde

I have been fighting with this almost all day. Can anyone explain what I am doing incorrectly?

  • I've had a similar problem when using the Awesome WM in Fedora. My guess was that there was some kind of daemon that was not started correctly. Didn't solve it though... – Kotte Oct 15 '13 at 9:46

I also had this issue after upgrading to wheezy. After some searching I created a bug report that resulted in the following section in the wheezy release notes:

ConsoleKit in Debian 7.0 does not consider sessions started using startx or display managers lacking consolekit integration (e.g. xdm or slim) as local, which might prevent access to some devices.

We recommend using one of gdm3, kdm or lightdm instead.

So I guess you will have to switch your DM.

  • Thank you, but I have stopped using both Slim and console-kit. I now login to a tty console and run startx. And I switched from network-manager to ceni. So, while I never solved the problem, I have worked around it and I'm happy. – Tim Mar 29 '14 at 16:50
  • I guess this works much better with systemd, doesn't it? – Pavel Šimerda Apr 26 '14 at 18:29

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.