1

I have installed Open Wrt on my TP-Link TL-WR740N/ND v4. Everything works fine but the Imagemagick. I have installed it into ram (no enough space on rom ) with opkg

# opkg install imagemagick imagemagick-png imagemagick-jpeg imagemagick-tools -d ram
...
...
# opkg list-installed | grep imagema
imagemagick - 6.7.8-1
imagemagick-jpeg - 6.7.8-1
imagemagick-png - 6.7.8-1
imagemagick-tools - 6.7.8-1

but not I am getting UnableToOpenConfigureFile as there is no configuration files. Anyone knows how to omit that ?

# convert -debug configure picture.jpeg picture.jpeg 
2013-10-14T14:45:24+00:00 0:00.010 0.010u 6.7.8 Configure convert[2677]: utility.c/ExpandFilenames/939/Configure
  Command line: convert {-debug} {configure} {picture.jpeg} {picture.jpeg}
2013-10-14T14:45:24+00:00 0:00.020 0.020u 6.7.8 Configure convert[2677]: configure.c/GetConfigureOptions/564/Configure
  Searching for configure file: "/usr/share/ImageMagick-6.7.8/coder.xml"
2013-10-14T14:45:24+00:00 0:00.020 0.020u 6.7.8 Configure convert[2677]: configure.c/GetConfigureOptions/564/Configure
  Searching for configure file: "/usr/lib/ImageMagick-6.7.8/config/coder.xml"
2013-10-14T14:45:24+00:00 0:00.030 0.030u 6.7.8 Configure convert[2677]: configure.c/GetConfigureOptions/564/Configure
  Searching for configure file: "/etc/ImageMagick/coder.xml"
2013-10-14T14:45:24+00:00 0:00.030 0.030u 6.7.8 Configure convert[2677]: configure.c/GetConfigureOptions/564/Configure
  Searching for configure file: "/usr/share/doc/ImageMagick-6.7.8/coder.xml"
2013-10-14T14:45:24+00:00 0:00.030 0.030u 6.7.8 Configure convert[2677]: configure.c/GetConfigureOptions/564/Configure
  Searching for configure file: "/root/.magick/coder.xml"
2013-10-14T14:45:24+00:00 0:00.060 0.060u 6.7.8 Configure convert[2677]: configure.c/GetConfigureOptions/564/Configure
  Searching for configure file: "/usr/share/ImageMagick-6.7.8/magic.xml"
2013-10-14T14:45:24+00:00 0:00.070 0.070u 6.7.8 Configure convert[2677]: configure.c/GetConfigureOptions/564/Configure
  Searching for configure file: "/usr/lib/ImageMagick-6.7.8/config/magic.xml"
2013-10-14T14:45:24+00:00 0:00.070 0.070u 6.7.8 Configure convert[2677]: configure.c/GetConfigureOptions/564/Configure
  Searching for configure file: "/etc/ImageMagick/magic.xml"
2013-10-14T14:45:24+00:00 0:00.070 0.070u 6.7.8 Configure convert[2677]: configure.c/GetConfigureOptions/564/Configure
  Searching for configure file: "/usr/share/doc/ImageMagick-6.7.8/magic.xml"
2013-10-14T14:45:24+00:00 0:00.070 0.070u 6.7.8 Configure convert[2677]: configure.c/GetConfigureOptions/564/Configure
  Searching for configure file: "/root/.magick/magic.xml"
2013-10-14T14:45:24+00:00 0:00.090 0.090u 6.7.8 Configure convert[2677]: configure.c/GetConfigureOptions/564/Configure
  Searching for configure file: "/usr/share/ImageMagick-6.7.8/delegates.xml"
2013-10-14T14:45:24+00:00 0:00.090 0.090u 6.7.8 Configure convert[2677]: configure.c/GetConfigureOptions/564/Configure
  Searching for configure file: "/usr/lib/ImageMagick-6.7.8/config/delegates.xml"
2013-10-14T14:45:24+00:00 0:00.090 0.090u 6.7.8 Configure convert[2677]: configure.c/GetConfigureOptions/564/Configure
  Searching for configure file: "/etc/ImageMagick/delegates.xml"
2013-10-14T14:45:24+00:00 0:00.090 0.090u 6.7.8 Configure convert[2677]: configure.c/GetConfigureOptions/564/Configure
  Searching for configure file: "/usr/share/doc/ImageMagick-6.7.8/delegates.xml"
2013-10-14T14:45:24+00:00 0:00.100 0.090u 6.7.8 Configure convert[2677]: configure.c/GetConfigureOptions/564/Configure
  Searching for configure file: "/root/.magick/delegates.xml"
2013-10-14T14:45:24+00:00 0:00.100 0.090u 6.7.8 Configure convert[2677]: delegate.c/LoadDelegateList/1228/Configure
  Loading delegate configuration file "built-in" ...
convert: UnableToOpenConfigureFile `delegates.xml' @ warning/configure.c/GetConfigureOptions/591.
convert: NoDecodeDelegateForThisImageFormat `picture.jpeg' @ error/constitute.c/ReadImage/544.
convert: NoImagesDefined `picture.jpeg' @ error/convert.c/ConvertImageCommand/3044.

EDIT

I have now tried to copy my delegates from ubuntu box to router but no luck.

Now I just got rid of UnableToOpenConfigureFile

# convert -debug configure picture.jpeg picture.jpeg 
2013-10-14T15:14:34+00:00 0:00.000 0.000u 6.7.8 Configure convert[2789]: utility.c/ExpandFilenames/939/Configure
  Command line: convert {-debug} {configure} {picture.jpeg} {picture.jpeg}
2013-10-14T15:14:34+00:00 0:00.010 0.000u 6.7.8 Configure convert[2789]: configure.c/GetConfigureOptions/564/Configure
  Searching for configure file: "/usr/share/ImageMagick-6.7.8/coder.xml"
2013-10-14T15:14:34+00:00 0:00.010 0.000u 6.7.8 Configure convert[2789]: configure.c/GetConfigureOptions/564/Configure
  Searching for configure file: "/usr/lib/ImageMagick-6.7.8/config/coder.xml"
2013-10-14T15:14:34+00:00 0:00.020 0.000u 6.7.8 Configure convert[2789]: configure.c/GetConfigureOptions/564/Configure
  Searching for configure file: "/etc/ImageMagick/coder.xml"
2013-10-14T15:14:34+00:00 0:00.020 0.000u 6.7.8 Configure convert[2789]: configure.c/GetConfigureOptions/564/Configure
  Searching for configure file: "/usr/share/doc/ImageMagick-6.7.8/coder.xml"
2013-10-14T15:14:34+00:00 0:00.020 0.000u 6.7.8 Configure convert[2789]: configure.c/GetConfigureOptions/564/Configure
  Searching for configure file: "/root/.magick/coder.xml"
2013-10-14T15:14:34+00:00 0:00.020 0.000u 6.7.8 Configure convert[2789]: coder.c/LoadCoderList/693/Configure
  Loading coder configuration file "/usr/share/ImageMagick-6.7.8/coder.xml" ...
2013-10-14T15:14:34+00:00 0:00.050 0.030u 6.7.8 Configure convert[2789]: configure.c/GetConfigureOptions/564/Configure
  Searching for configure file: "/usr/share/ImageMagick-6.7.8/magic.xml"
2013-10-14T15:14:34+00:00 0:00.060 0.040u 6.7.8 Configure convert[2789]: configure.c/GetConfigureOptions/564/Configure
  Searching for configure file: "/usr/lib/ImageMagick-6.7.8/config/magic.xml"
2013-10-14T15:14:34+00:00 0:00.060 0.040u 6.7.8 Configure convert[2789]: configure.c/GetConfigureOptions/564/Configure
  Searching for configure file: "/etc/ImageMagick/magic.xml"
2013-10-14T15:14:34+00:00 0:00.060 0.040u 6.7.8 Configure convert[2789]: configure.c/GetConfigureOptions/564/Configure
  Searching for configure file: "/usr/share/doc/ImageMagick-6.7.8/magic.xml"
2013-10-14T15:14:34+00:00 0:00.060 0.040u 6.7.8 Configure convert[2789]: configure.c/GetConfigureOptions/564/Configure
  Searching for configure file: "/root/.magick/magic.xml"
2013-10-14T15:14:34+00:00 0:00.080 0.060u 6.7.8 Configure convert[2789]: configure.c/GetConfigureOptions/564/Configure
  Searching for configure file: "/usr/share/ImageMagick-6.7.8/delegates.xml"
2013-10-14T15:14:34+00:00 0:00.080 0.060u 6.7.8 Configure convert[2789]: configure.c/GetConfigureOptions/564/Configure
  Searching for configure file: "/usr/lib/ImageMagick-6.7.8/config/delegates.xml"
2013-10-14T15:14:34+00:00 0:00.080 0.060u 6.7.8 Configure convert[2789]: configure.c/GetConfigureOptions/564/Configure
  Searching for configure file: "/etc/ImageMagick/delegates.xml"
2013-10-14T15:14:34+00:00 0:00.080 0.060u 6.7.8 Configure convert[2789]: configure.c/GetConfigureOptions/564/Configure
  Searching for configure file: "/usr/share/doc/ImageMagick-6.7.8/delegates.xml"
2013-10-14T15:14:34+00:00 0:00.090 0.060u 6.7.8 Configure convert[2789]: configure.c/GetConfigureOptions/564/Configure
  Searching for configure file: "/root/.magick/delegates.xml"
2013-10-14T15:14:34+00:00 0:00.090 0.060u 6.7.8 Configure convert[2789]: delegate.c/LoadDelegateList/1228/Configure
  Loading delegate configuration file "/usr/share/ImageMagick-6.7.8/delegates.xml" ...
convert: NoDecodeDelegateForThisImageFormat `picture.jpeg' @ error/constitute.c/ReadImage/544.
convert: NoImagesDefined `picture.jpeg' @ error/convert.c/ConvertImageCommand/3044.
  • Try to copy all *.xml files from /etc/ImageMagick. – jofel Oct 14 '13 at 15:47
  • @jofel the problem is that I don't have any of those files 'installed' by opkg in my system. – Patryk Oct 16 '13 at 11:35
2

You need to install the configure files (delegates.xml etc.) to a directory which imagemagick searches (/root/.magick/ or /usr/share/doc/ImageMagick-6.7.8/ or /usr/share/ImageMagick-6.7.8/ or /usr/lib/ImageMagick-6.7.8/config/ or /etc/ImageMagick/.)

If it should search in another directory, you can e.g. symlink on of these directories to the correct one, or need to recompile imagemagick.

  • Those files have not been installed with ImageMagick by opkg. May the package be broken then ? – Patryk Oct 16 '13 at 11:36
  • 1
    @Patryk Yes, the package seems to be broken - it seems that the maintainers forgot to package the configuration file in a (possible separate) package. Feel free to report this bug to the responsible persons. – jofel Oct 16 '13 at 15:49

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.