I have Crunchbang 64 bit, a debian wheezy distro. Debian have a rebranded Firefox called Iceweasel and a rebranded Thunderbird called Icedove. But I don't want any of them.

I was able to install the latest version of Firefox by adding Linux Mint repo, and installing it from there. I did the same and installed Thunderbird, but it tells me that I'm not using the latest version, I need to download it from their site.

I downloaded it from the site and when i run

sudo sh run-mozilla.sh I get run-mozilla.sh: Cannot execute

I tried different commands, none worked. Do I need to chmod it?

  • 2
    Two things: 1) why sudo; 2) what's wrong with Debian's rebranded packages which are built from the same sources with just a different set of icons? – peterph Oct 14 '13 at 12:02
  • As @peterph said, icedove is the same as Thunderbird. They just use different icons (because of the license Mozilla uses for the icons). And because they're using different icons they are not allowed to call it Thunderbird anymore. But everything else is the same. So where is the point in downloading the binaries from Mozilla? That just increases the work to keep the software up-to-date. (which is very critical for that kind of software!) – binfalse Oct 14 '13 at 12:07
  • The reason why it doesn't work might easily be, that you have a 64bit system and the Mozilla binaries are only 32bit - you'd need to install 32bit-compatibility packages. But really - just use IceDove/IceWeasel/IceApe (the last one is rebranded Seamonkey). – peterph Oct 14 '13 at 12:11
  • 1
    It might be a good idea to show us the permissions of the file when asking if you need to chmod it :). – terdon Oct 14 '13 at 14:07
  • @peterph The problem isn't the rebranding, but finding the right versions of your favorite extensions for the older version on icedove packaged in stable. – jordanm Oct 14 '13 at 16:12

First of all, don't add mint repositories to Debian, not a good idea. Mint is based on Ubuntu which, while based on Debian, is not 100% compatible with Debian repositories. Mixing them is likely to cause trouble. Instead, add LMDE (Linux Mint Debian Edition) repositories. LMDE is Debian and is 100% compatible with the Debian repos. As long as you're running Debian testing, that should work with no problems.

Second, as others have pointed out, this is really truly not worth the effort.

Anyway, the error you get is actually

run-mozilla.sh: Cannot execute .

The . is important, it shows that the script expects an argument and since you don't give it one, it takes the current directory. The script is not an installer and is usually called by another script, not directly.

To install the thunderbird binaries, follow the instructions here:

wget 'http://releases.mozilla.org/pub/mozilla.org/thunderbird/releases/3.1.4/linux-i686/en-US/thunderbird-3.1.4.tar.bz2 -O- | ' sudo tar xj -C /opt && sudo ln -s /opt/thunderbird/thunderbird /usr/bin/thunderbird

However, this will install the 32bit thunderbird which won't work on a 64bit system unless you have multiarch installed. You will also need to bring in the dependencies manually. Please don't do this, either install the deb from LMDE or just use icedove which is thunderbird with different icons.

| improve this answer | |
  • Adding LMDE, which is based on testing, will hose his system if he is running stable. – jordanm Oct 14 '13 at 16:13
  • @jordanm true, caveat added, thanks. Still, that would be no worse than if he adds a Mint one. – terdon Oct 14 '13 at 16:21
  • @terdon cheer for your answer, your link there is broken. – Stígandr Dec 26 '14 at 8:34

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.