2

I'm new to linux and am using Linux Mint 15 Olivia. I am running it alongside windows 7 and I want to increase the size of my current linux hard drive partition. I read somewhere that I should install the GParted package, but I get this error:

$ sudo apt-get install gparted
Reading package lists... Done
Building dependency tree 
Reading state information... Done
E: Unable to locate package gparted

And then someone told me I should try entering:

$ sudo apt-get update

And then I keep getting this at the bottom of the installation log:

W: GPG error: http://archive.canonical.com raring Release: The following signatures were invalid: BADSIG 40976EAF437D05B5 Ubuntu Archive Automatic Signing Key

Then I tried running:

sudo apt-key adv --recv-keys --keyserver keyserver.ubuntu.com 40976EAF437D05B5

and get the output:

Executing: gpg --ignore-time-conflict --no-options --no-default-keyring --secret-keyring /tmp/tmp.q0RYkOedsz --trustdb-name /etc/apt//trustdb.gpg --keyring /etc/apt/trusted.gpg --primary-keyring /etc/apt/trusted.gpg --recv-keys --keyserver keyserver.ubuntu.com 40976EAF437D05B5 gpg: requesting key 437D05B5 from hkp server keyserver.ubuntu.com gpg: key 437D05B5: "Ubuntu Archive Automatic Signing Key " not changed gpg: Total number processed: 1 gpg: unchanged: 1

And when I run:

for f in /etc/apt/sources.list.d /etc/apt/sources.list.d/*; do echo "$f:"; cat "$f"; done

I get:

http://pastebin.com/eaDM7ive

I already changed the softer source to my local mirror. As I said I am very new to all of this. Any ideas about what could be wrong?

0

You need to add the repository's key to your key list. Run this command:

sudo apt-key adv --recv-keys --keyserver keyserver.ubuntu.com 40976EAF437D05B5 

Your next problem is that you seem to have commented out the single repository listed in your /etc/apt/sources.list. This file contains a list of repositories that will be searched for available software. Any line that begins with # is ignored.

So, open that file with an editor (sudo pluma /etc/apt/sources.list) and make it look like this:

deb http://packages.linuxmint.com/ olivia main upstream import
deb http://archive.ubuntu.com/ubuntu/ raring main restricted universe multiverse
deb http://archive.ubuntu.com/ubuntu/ raring-updates main restricted universe multiverse
deb http://security.ubuntu.com/ubuntu/ raring-security main restricted universe multiverse
deb http://archive.canonical.com/ubuntu/ raring partner
deb http://packages.medibuntu.org/ raring free non-free

Then, save the file and try and install gparted again:

$ sudo apt-get update
$ sudo apt-get install gparted
  • I ran the command you suggested but I still got the same error when I tried to run >sudo apt-get update.. – Noosgam Oct 13 '13 at 16:02
  • @user2789331 Could you update your question with the exact command you ran (sudo apt-key ...) and the exact error message received? – terdon Oct 13 '13 at 16:06
  • @user2789331 also, please edit your question and post the output of for f in /etc/apt/sources.list /etc/apt/sources.d/*; do echo "$f:"; cat "$f"; done. – terdon Oct 13 '13 at 16:08
  • @user2789331 I believe #terdon meant /etc/apt/sources.list.d. – Joseph R. Oct 13 '13 at 17:01
  • @JosephR. I ran the modified command and get an output with a lot of url's but the site does not allow me to post more than 2, since I'm new to stackexchange. Are these links relevant to the problem? And thanks for your help – Noosgam Oct 13 '13 at 17:12
0

I'm not sure what was wrong with apt-get, but using the Software Manager fixed this for me.

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.