After a recent upgrade in my Arch Linux x64 system, I keep getting this warning message after installing or removing packages with pacman.

(gconftool-2:5207): GConf-WARNING **: Client failed to connect to the D-BUS daemon:
/usr/bin/dbus-launch terminated abnormally with the following error: No protocol specified
Autolaunch error: X11 initialization failed.

So, far I have not seen any ill effects from this (that I know of), but I would like to make this warning go away.


I can consistently reproduce this by installing or uninstalling GNOME Do. Both of the following commands result in the output above.

$ sudo pacman -S gnome-do
$ sudo pacman -Rns gnome-do

Running xhost + seems to temporarily alleviate the warning (at least until I reboot). I can run xhost - and the warning returns.

UPDATE This problem went away after a few upgrades (i.e. pacman -Syu).

  • Are you using XFCE? I found this thread: code.google.com/p/acpi-eeepc-generic/issues/detail?id=47
    – slm
    Oct 13, 2013 at 13:22
  • @sim, before doing the update (pacman -Syu), I only had GNOME installed. I immediately began seeing the warning after the update. Sometime after the warning started appearing I did install XFCE, KDE, and Cinnamon as well. I am playing around with different desktop environments trying to decide which one I want to use (since I'm ever increasingly disliking GNOME 3). Where it not for that I probably wouldn't have noticed it anymore. The thread you posted though doesn't seem to help. I am only seeing this when using pacman. Oct 14, 2013 at 0:25
  • 1
    As far as I understand what's going on, it's your display manager init script (such as xdm or gdm3) is trying to start X, creates a per-user instance of D-Bus and for some reason GConf fails to connect to its socket. A common reason for such a problem might be just in that your per-user instance of D-bus is started with wrong permissions, it must run under your UID (see askubuntu.com/questions/135573/… and bbs.archlinux.org/viewtopic.php?id=151914). Try ps -axfl and look into UIDs and arguments of your processes. Oct 14, 2013 at 10:39

1 Answer 1



export $(dbus-launch)

and then try any dbus based commands.

  • 2
    could you explain what that command is doing ? It helped me fix my error but I would like to understand what happened. Edit: I think it logs the user in as you would normally via the desktop environment, but in my case I was only logged in via ssh. so dbus-launch is probably launching that session, right? dbus.freedesktop.org/doc/dbus-launch.1.html
    – rwenz3l
    Mar 20, 2015 at 9:58
  • It initializes the dbus-daemon. Ideally that command is executed within a user's login script. More details here
    – Stark07
    Mar 20, 2015 at 12:16
  • worked for me on ubuntu 14.04 LTS. Had to install dbus-x11 and run the command above
    – dubnde
    Dec 11, 2015 at 12:03
  • In my case this helped - however indirectly since I got an error that I need to run 'apt install dbus-x11' which I did and then everything worked as expected.
    – Wojtek_B
    Sep 28, 2022 at 16:22

You must log in to answer this question.

Not the answer you're looking for? Browse other questions tagged .