in KDE, when I plug a USB storage device, I see a nautilus window automatically open, and I'm obliged to use nautilus if I want to umount it properly Dolphin gives the following error:

org.freedesktop.Hal.Device.Volume.NotMountedByHal: Device to unmount is not in /media/.hal-mtab so it is not mounted by HAL.

How can I specify that when I use KDE, I want HAL to handle usb storage automatic mounting ? I don't know what gnome-mechanism automatically mounts usb devices, but I guess I'll have to disable it too? I'm using fedora 13.

  • You could try using this in a terminal " gconftool --type Boolean --set /apps/nautilus/preferences/media_automount false" I have a long answer but it will not let me post so tought I would at least put this up – Steve Burdine Aug 21 '10 at 15:50
  • @Steve Burdine : I couldn't find any gconftool command, so I tried gconftool-2, but I got this answer : "Erreur lors de la définition de la valeur : Le contact du serveur de configuration a échoué ; (Détails - 1: La connexion à la session a échoué : Did not receive a reply. Possible causes include: the remote application did not send a reply, the message bus security policy blocked the reply, the reply timeout expired, or the network connection was broken.)" Too bad you can't post – greg0ire Aug 21 '10 at 16:01

It seems that I have solved my problem. I tried to launch nautilus in konsole and it crashed with the same message I put in my comment. Then I launched nautilus using krunner and this time, it worked, and I could eject the usb device. Now the solution to the problem is to configure auto-mounting in KDE (I did it via the New device notification applet). Once auto mounting authorized in KDE, it seems to take priority over gnome, and you can handle devices from dolphin.

| improve this answer | |

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.