I am getting an error as "GDM could not write to your authorization file" if I try to login as a non root user in my RHEL system. I restarted the machine hoping that the tmp files will be cleared and so I will not get this error on booting. However, I still get the error. I ran the df -h command and I got the below output.

Filesystem            Size  Used Avail Use% Mounted on
/dev/sda2              39G   39G     0 100% /
/dev/sda5             102G   33G   64G  34% /opt
/dev/sda1              99M   12M   83M  13% /boot
tmpfs                 1.5G     0  1.5G   0% /dev/shm

I read in this link that clearing log files should help. But logrotate should be doing it and even if I delete the log files I might encounter the same error in future. Is there any specific reason for this error? What should I try to increase the space on /dev/sda2 so that I can ensure non-root users can login to the machine?


Your system has run out of disk space. Notice this line:

/dev/sda2              39G   39G     0 100% /

You likely have a large file (probably a log file) that is full of error messages that went unchecked and has consumed all your disk space.

Check your /home/user directories for this file, .xsession-errors, and see if one of them isn't consuming all your free space.

I would use one of the answers from this question, titled: Sorting files according to size recursively, that shows you the top 10 largest files on your system:

$ du -ah /home | grep -v "/$" | sort -h | tail -6

Change it based on your own needs.


$ du -ah /home/saml/tst | grep -v "/$" | sort -h | tail -6
14M /home/saml/tst/util-linux-2.19/po
43M /home/saml/tst/89704
43M /home/saml/tst/89704/dirA
43M /home/saml/tst/89704/dirA/file1.txt
48M /home/saml/tst/util-linux-2.19
96M /home/saml/tst
  • Thanks @slm. I was having lots of image files that were occupying the disk space. I cleared them. However, I will try running these commands to find out what actually consumes that much memory. – Ramesh Oct 11 '13 at 21:35

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.