4

It threw errors about kernel sources missing. So, I looked and sure enough this box doesn't have them. The documentation I have says to install them via sysinstall. That failed both automatically and manually configured server references.

I then found elsewhere that sysinstall is no longer supported and that sources should be pulled with Subversion. I pulled the sources into /usr/src with subversion. Lsof still pukes on compile. The Makefile dependency that it is missing appears to be /usr/src/sys/kern/kern_lockf.c. I've got a /usr/src/sys/kern with several files, but no kern_lockf.c anywhere to be found.

Supposedly I have the current sources and the current ports. What's going on?

  • If kern_lockf.c is missing, you have an incomplete source tree. How did you pull the source? – D_Bye Oct 16 '13 at 16:49
  • Standard svn checkout of the the /usr/src tree from the FreeBSD servers. It appeared to succeed and did indeed download kernel files. Just none of them are named kern_lockf.c. Got a method that works for you and results in kern_lockf.c actually showing up? I'd be more than happy to try something else that you know to work and see if it works for me! – Brian Knoblauch Oct 16 '13 at 19:42
  • Did you have a /usr/src/sys directory before you did the checkout? If so, it's possible that svn got in a muddle and failed to pull it from the servers. I have only just hit this same problem migrating from CVS to svn. I fixed it by completely clearing out /usr/src and rerunning the checkout. Worth a shot! – D_Bye Oct 18 '13 at 13:17
  • Negative, there was no /usr/src at all. Subversion created it all. I will try deleting it all and downloading again though. – Brian Knoblauch Oct 18 '13 at 13:44
  • Still working on this one. Trying to pull sources via sysinstall is an epic fail. Doesn't matter which mirror I choose, they all fail with "Unable to transfer sbase...". I've also tried pulling via HTTP manual mirror, but it has a ardcoded directory structure and none of the mirrors I've tried match it. Very annoying. – Brian Knoblauch Dec 12 '13 at 19:05
2

Ultimately, the following command line appears to have solved the problem. I don't recall the original source (or command line) I had used, so I don't know if the documentation I was using was wrong or it was a problem with the mirror:

svn checkout svn://svn.freebsd.org/base/release/9.2.0/ /usr/src
  • 1
    there is this thing called svnup (pkg_add -r svnup should do) which is a a bit like cvsup used to be - you run it and it does the job. It has a tiny config file where you just select a mirror that matches your location. Still the whole "we deprecate those working ways and leave you with the new ones that have less mirrors and new bugs" thing is highly annoying. – Florian Heigl Jan 20 '14 at 14:03

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.