0

My friend and I were doing some firewall configurations and in the meanwhile he thought it was a good idea to type service iptables panic.

Now we cannot put the firewall back on the original state (default). It blocks all connections. We have tried everything:

iptables -F service 
iptables save service 
iptables stop service 
iptables start etc....

What can we do to restore original and clean firewall configurations?

  • I just tried running your command on a normal CentOS 6.4 Desktop installation could not reproduce your error so you could have further issues. What error are you getting when trying to start the service and what do you see in the various log files? – M_dk Oct 11 '13 at 3:31
0

Running iptables commands from the commandline only alters the running configuration. Depending on how you set up iptables to save configurations in /etc/sysconfig/iptables-config, your configuration might still saved in saved in the file /etc/sysconfig/iptables/iptables.save To restore the configuration saved in this file run:

# iptables-restore /etc/sysconfig/iptables.save

If you have no configuration saved, you can set the default INPUT policy to accept by running

# iptables -P INPUT ACCEPT
|improve this answer|||||
-2

The only thing that worked was to:

$ setup

and activate all services on firewall again.

|improve this answer|||||

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.