I have a RHEL6 server which we connect via XDMCP. If I start xdm (xdm &) it works but the login screen is the old xdm simple login and not gdm. Our RHEL5 servers connect to gdm just fine. The problem is that GDM isn't running. When I try to launch GDM (gdm &) it gives me the following message:

** (gdm-binary:3229): WARNING **: Couldn't connect to system bus: Failed to connect to socket /var/run/dbus/system_bus_socket: No such file or directory

I've also tried using (gdm-binary &) and get the same message.

cat /etc/gdm/custom.conf
# GDM configuration storage

In /etc/X11/xdm/Xaccess I have the following uncommented: * #any host can get a login window

In /etc/X11/xdm/xdm-config I have tried commenting and uncommenting the following: DisplayManager.requestPort: 0

I've referenced several tutorials such as:



  • Why you dont' use gdm service? Oct 10 '13 at 22:47
  • Which service is that? There doesn't seem to be an init script in /etc/init.d/. There is a file called /etc/gdm/Init/Default but it doesn't appear to be a normal init script.
    – Jeight
    Oct 10 '13 at 22:52
  • wow, do you compiled? Oct 10 '13 at 22:54
  • A gdm service doesn't appear when using ntsysv either so I don't think that's an option on RHEL6
    – Jeight
    Oct 10 '13 at 22:55
  • 1
    @Jeight: probably fixed by installing the dbus package and maybe issuing a service messagebus restart
    – ninjalj
    Oct 11 '13 at 15:50

This warning:

** (gdm-binary:3229): WARNING **: Couldn't connect to system bus: Failed to connect to socket /var/run/dbus/system_bus_socket: No such file or directory

means that the system D-Bus message bus is not running. D-Bus provides message buses that programs can use to communicate with other programs: there is usually a system message bus, and a message bus per user session.

On RHEL, the system message bus is started by the messagebus init script, provided by the dbus package.

To start the system message bus you'll have to install the dbus package, and probably issue a service messagebus restart.

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.