2

I spent an entire day trying to figure out why my USB ubuntu installation was not being persistent. Yes, I did check the "persistence" option and assigned a file size for it during installation. I've tried installing it with Pendrive's Universal Installer and LiveUSBCreator's installer. Both have failed so far. My test to see if persistence was working was that I would boot into it (Select "I want to try ubuntu" on the boot menu for the usb) and create a file on the desktop using "touch Testfile". Then I would reboot to see if the file was still there. But it always disappears at reboot. I even tried installing some programs and they would be gone too. I've tried Ubuntu 12.04 and Ubuntu 11.10. If I selected persistence at install, can anyone tell me why this isn't working? Bad Ubuntu version? (I've tried two USB flash drives so no problem there.)

2

This is because you are using a live CD and everything is being loaded into memory. Nothing is actually getting saved on your USB drive. It will start working correctly once you install Ubuntu on the USB or save the file explicitly to the USB. When you select "I want to try Ubuntu" it's not installing anything and the RAM memory is dumped when you reboot, causing the file to be deleted.

| improve this answer | |
  • But how do I do that? I thought that was what the installer did. Can I boot into the live CD and install it on itself? – Shell Oct 10 '13 at 16:16
  • Here are the instructions in detail: help.ubuntu.com/community/LiveCD/Persistence – Jeight Oct 10 '13 at 16:24
  • Basically format the USB, unmount it, and then create the file ext called casper-rw. – Jeight Oct 10 '13 at 16:31
  • Is it possible to just directly have a full installation on my 8 GB usb stick? Persistence seems to be an alternative to a full installation. – Shell Oct 10 '13 at 16:33
  • That's the route I would take, but it's all personal opinion. – Jeight Oct 10 '13 at 16:35

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.