The problem concerns a driver support regression for the RTL8192CUS WLAN chip under antiX 13.1, a Debian Wheezy (stable) based distribution. The chip actually resides in a Edimax EW-7811Un 802.11n wireless adapter.

First, here is some general system information.

$ inxi -F
System:    Host: 4000cdt Kernel: 3.7.10-antix.3-486-smp i686 (32 bit) 
           Desktop: IceWM 1.3.7 Distro: antiX-13.1_386-full Luddite 19 June 2013
Machine:   No /sys/class/dmi, using dmidecode: you must be root to run dmidecode
CPU:       Single core Pentium II (Deschutes) (-UP-) cache: 512 KB flags: (pae) clocked at 233.275 MHz 
Graphics:  Card: Chips and F65555 HiQVPro X.Org: 1.12.4 drivers: chips (unloaded: fbdev,vesa) Resolution: [email protected] 
           GLX Renderer: Gallium 0.4 on softpipe GLX Version: 2.1 Mesa 8.0.5
Network:   Card: Edimax EW-7811Un 802.11n Wireless Adapter [Realtek RTL8188CUS] 
           IF: N/A state: N/A mac: N/A
Drives:    HDD Total Size: 40.0GB (8.7% used) 1: id: /dev/sda model: TOSHIBA_MK4032GA size: 40.0GB 
Partition: ID: / size: 9.9G used: 3.0G (32%) fs: ext4 ID: /home size: 25G used: 284M (2%) fs: ext4 
           ID: swap-1 size: 2.15GB used: 0.00GB (0%) fs: swap 
Sensors:   System Temperatures: cpu: 71.0C mobo: N/A 
           Fan Speeds (in rpm): cpu: N/A 
Info:      Processes: 88 Uptime: 2:57 Memory: 72.4/151.4MB Client: Shell (bash) inxi: 1.9.9 

During booting, the following errors appear on the screen, caused while executing the /etc/network/if-pre-up.d/linux-wlan-ng-pre-up script:

FATAL: Module p80211 not found.

Failed to load p80211.ko.

Listening on LPF/wlan0/00:1f:1f:bf:45:7a
Sending on   LPF/wlan0/00:1f:1f:bf:45:7a
Sending on   Socket/fallback
DHCPDISCOVER on wlan0 to port 67 interval 7
DHCPDISCOVER on wlan0 to port 67 interval 10
DHCPDISCOVER on wlan0 to port 67 interval 14
DHCPDISCOVER on wlan0 to port 67 interval 17
DHCPDISCOVER on wlan0 to port 67 interval 13
No DHCPOFFERS received.
No working leases in persistent database - sleeping.

The error messages can be reproduced by issuing respectively the sudo modprobe p80211 and sudo dhclient -v wlan0 commands.

The following modules are loaded:

$ lsmod
Module                  Size  Used by
mperf                    870  0 
cpufreq_stats           2600  0 
cpufreq_powersave        575  0 
cpufreq_conservative     3562  0 
ppdev                   4124  0 
lp                      6127  0 
uinput                  5093  1 
nfsd                  156046  2 
auth_rpcgss            19755  1 nfsd
nfs_acl                 1576  1 nfsd
nfs                    88586  0 
lockd                  42731  2 nfs,nfsd
fscache                21695  1 nfs
sunrpc                122417  6 nfs,nfsd,auth_rpcgss,lockd,nfs_acl
af_packet              19031  6 
dm_crypt               10846  0 
arc4                    1400  2 
rtl8192cu              45534  0 
rtlwifi                43564  1 rtl8192cu
rtl8192c_common        23999  1 rtl8192cu
mac80211              192647  3 rtlwifi,rtl8192c_common,rtl8192cu
cfg80211              123731  2 mac80211,rtlwifi
microcode               8484  0 
evdev                   6815  10 
mac_hid                 2214  0 
psmouse                52159  0 
pcspkr                  1273  0 
serio_raw               3177  0 
i2c_piix4               6769  0 
toshiba_acpi           10065  0 
sparse_keymap           1937  1 toshiba_acpi
parport_pc             23969  1 
rfkill                 10599  3 cfg80211,toshiba_acpi
parport                21942  3 lp,ppdev,parport_pc
wmi                     6240  1 toshiba_acpi
pcmcia                 24870  0 
battery                 5391  0 
yenta_socket           15802  0 
ac                      1753  0 
pcmcia_rsrc             5995  1 yenta_socket
pcmcia_core             8446  3 pcmcia,pcmcia_rsrc,yenta_socket
processor              23837  1 
button                  3513  0 
btrfs                 555574  0 
zlib_deflate           15207  1 btrfs
dm_mod                 51354  1 dm_crypt
floppy                 41663  0 
fan                     1818  0 
thermal                 6606  0 
thermal_sys            10423  3 fan,thermal,processor

Proof that this is not an authentication issue:

$ sudo cat /var/log/dmesg |grep wlan0
[   36.321107] IPv6: ADDRCONF(NETDEV_UP): wlan0: link is not ready
[   38.921480] wlan0: authenticate with 00:xx:xx:xx:xx:xx
[   38.971473] wlan0: send auth to 00:xx:xx:xx:xx:xx (try 1/3)
[   38.996892] wlan0: authenticated
[   39.000218] wlan0: associate with 00:xx:xx:xx:xx:xx (try 1/3)
[   39.055578] wlan0: RX AssocResp from 00:xx:xx:xx:xx:xx (capab=0x411 status=0 aid=2)
[   39.056549] wlan0: associated
[   39.056781] IPv6: ADDRCONF(NETDEV_CHANGE): wlan0: link becomes ready
[   49.062856] wlan0: disassociating from 00:xx:xx:xx:xx:xx by local choice (reason=3)
[   49.086100] wlan0: deauthenticating from 00:xx:xx:xx:xx:xx by local choice (reason=3)
[   50.431396] wlan0: authenticate with 00:xx:xx:xx:xx:xx
[   50.481575] wlan0: send auth to 00:xx:xx:xx:xx:xx (try 1/3)
[   50.684150] wlan0: send auth to 00:xx:xx:xx:xx:xx (try 2/3)
[   50.888146] wlan0: send auth to 00:xx:xx:xx:xx:xx (try 3/3)
[   51.092212] wlan0: authentication with 00:xx:xx:xx:xx:xx timed out

$ sudo iwconfig
wlan0     IEEE 802.11bgn  ESSID:off/any  
          Mode:Managed  Access Point: Not-Associated   Tx-Power=20 dBm   
          Retry  long limit:7   RTS thr=2347 B   Fragment thr:off
          Encryption key:off
          Power Management:off

lo        no wireless extensions.

I already tried:

  • Installing the Linux driver from the Realtek site whilst uninstalling the linux-wlan-ng package and blacklisting the kernel's rtl8192cu module (what worked before with antiX 12M), and
  • Giving ipv6.disable=1 as a grub boot parameter to the kernel.


Why can the p80211 module not be found in a distribution that is supposed to be based on Debian Wheezy stable? How do I get DHCP working for this wireless adapter?

2 Answers 2


Why can the p80211 module not be found in a distribution that is supposed to be based on Debian Wheezy stable?

Because Anti hand rolled the kernel and probably left that module out. I ran into that on previous releases on different gear and informed the team of it.


I am answering you here instead of at the forum. The forum has a bug with posting code readouts. If posting at AntiX forums. Leave a space between / etc/issue or / ect anything or you'll get the message

You don't have permission to access /posting.php on this server.

Edit: as a quick fix solution like i have used in the past. You can run smxi as root out of X and install a Liqourix or Debian Kernel through a land line connection if available,


FATAL: Module p80211 not found. is usually an indication that the provided driver is outdated for the used kernel.

Moreover, current version 3.4.4_4749.20121105 of Realtek's driver will not compile with the latest Linux kernels. The solution consist in installing a downgraded kernel, compiling Realtek's driver on it and blacklisting the driver provided by the downgraded kernel.

Press Ctrl+Alt+F1 to obtain a command line outside the display manager. Execute the smxi.sh script that comes packed with Antix.

sudo smxi

For other GNU/Linux distributions, download the script from smxi.org. Follow the instructions. A dist-upgrade is not always necessary.

Choose: 6) kernel-options > 1) alternate-kernel-install

Kernel 3.6.0-11.dmz.1-liquorix-686 or lower work, kernel 3.7.0-10.dmz.1-liquorix-686 and higher do not. The latest stable kernel with long-term support that does work is 3.4.0-35.dmz.1-liquorix-686.

Be sure to reboot into the new kernel before proceeding. This kernel can be made to boot by default; simply edit...

sudo nano /boot/grub/menu.lst

Download the RTL8192CUS Linux driver from Realtek's web site.

Extract the driver. Then, save below bash script as setup.sh in the same directory as install.sh. (I got this script from Schoelje of SolydXK-distro fame.)

if [ $UID -ne 0 ]; then
  echo "Please, type the root password..."
  su -c "$0 $@"

apt-get install linux-headers-`uname -r`
apt-get install build-essential
rmmod rtl8192cu
chmod +x install.sh
echo "blacklist rtl8192cu" > /etc/modprobe.d/blacklist-rtl8192cu.conf
echo 8192cu >> /etc/modules

Make the script executable and execute it.

chmod +x setup.sh

After succesfull completion of the script, issue

sudo service network restart

Your RTL8192CUS wireless adapter should now function properly.

Use the Wicd application to connect to a wireless network. If always the same WLAN is used, one can also hardcode the security credentials in as follows:

sudo chmod 600 /etc/network/interfaces
sudo nano /etc/network/interfaces

# interfaces(5) file used by ifup(8) and ifdown(8)
auto lo
iface lo inet loopback

allow-hotplug eth0
iface eth0 inet dhcp

auto wlan0
iface wlan0 inet dhcp
    wpa-ssid xxxxxxxxxxx
    wpa-psk xxxxxxxxxxxx
  • In the end, I downgraded the Linux kernel further to 3.4.0-35.dmz.1-liquorix-686 in order to get the Yamaha OPL3-SA3 audio chip with its snd_opl3sa2 kernel module also working. Oct 16, 2013 at 12:31
  • Personally, I have not tried it, but following patched driver might work also with newer kernels. Oct 17, 2013 at 20:59

You must log in to answer this question.

Not the answer you're looking for? Browse other questions tagged .