I have installed Debian 6.0 OS (Linux kernel 2.6.32 )to test my USB Application as well as Driver.

My USB device is working fine on USB 2.0 Port without any issue.

But when i tried to connect the same device on USB 3.0 port at that time it enumerated as USB 2.0 Dvice not as USB 3.0 device which i have seen from dmesg output.

Following is log of dmesg output of my device which is enumerated as USB 2.0 device not as USB 3.0 even if USB device is connected in USB 3.0 port.

[  945.271232] usb 3-1.2: new high speed USB device using ehci_hcd and address 4

This is the output of lsmod with xhci support.

#lsmod | grep xhci
usbcore               123175  4 usbhid,ehci_hcd,xhci

This is the snap output of lsusb -v of my USB device

#lsusb -d 1552:0004 -v
 wMaxPacketSize     0x0200  1x 512 bytes

Please find the kernel and OS information below

#uname -a
Linux debian64 2.6.32-5-amd64 #1 SMP Mon Sep 23 22:14:43 UTC 2013 x86_64  

so, USB 2.0 support maximum packet size as 512 bytes while USB 3.0 supports maximum packet size as 1024 bytes. It seems that my device is enumerated as USB 2.0 Device not as USB 3.0 Device.

Is there any older kernel (2.6.32) issue which can not able to enumerate USB 3.0 Device or any thing else?

Please let me know any feedback if any one has faced this type of issue or any one knows about this issue.

  • Please let me know if any one has idea about this issue as soon as possible. Oct 9, 2013 at 11:35
  • 1
    Does your device correctly work at USB3.0 mode on the same or different machine with any other operating system? More importantly, if not confidential, what's the device?
    – bayindirh
    Oct 9, 2013 at 11:45
  • Yes. The device is working fine on ubuntu 12.04 LTS with Linux kernel 3.2.0 on USB 3.0 Port without any issue. Oct 9, 2013 at 12:05
  • Is there any issue regarding older linux kernel which i am using currently? Oct 9, 2013 at 12:17
  • What makes you think it is not USB 3? The message I see is usb 3-1.2:.
    – terdon
    Oct 9, 2013 at 15:37

1 Answer 1


As far as I can tell from your question, your device is indeed recognized as a USB 3 device. I don't see any problem here. The dmesg output you posted is

[ 945.271232] usb 3-1.2: new high speed USB device using ehci_hcd and address 4

Compare tat to what I get when connecting a USB 2 device:

[121568.653226] usb 2-1.4: new high-speed USB device number 13 using ehci-pci

  • But whenever I looked into the Device info using lsusb -v command at that i found that wMaxPacketSize is 512 Bytes which is for USB 2.0 not for USB 3.0 stack. wMaxPacketSize is 1024 Bytes for USB 3.0 Device. So it seems like the device is enumerated as USB 2.0 Device not USB 3.0 Device. I have also tried with other USB 3.0 devices in which i got the same problem. Also, USB 3.0 device is enumerated from xhci_hcd which loaded while running lsmod | grep xhci. But Device is failed to enumerate as USB 3.0 Device as per the dmesg and lsusb -v command output. Oct 10, 2013 at 4:23
  • @RiteshPrajapati please edit your question to include this information. At the moment, there is nothing in your question that indicates you have a problem. Include the lsusb -v output.
    – terdon
    Oct 10, 2013 at 4:37
  • I have edited my question with snap of USb device info of lsusb -v command output. I can not give full information as it is confidential details which i can not disclose. Oct 10, 2013 at 4:57
  • Please let me know if you need any more information regarding USB Device or Linux OS related information. Oct 10, 2013 at 5:05
  • usb 3 mean it is attacched to the port/hub 3 but high speed and ehci are 2.0.
    – Alex
    Oct 10, 2013 at 6:02

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.