I have a Dell Latitude E6510 with Slackware 14x86_64, gnome 3.6 (dropline), alps dualpoint touchpad and the latest 3.11.4 kernel.
My touchpad is being detected correctly and I have the touchpad settings in the gnome settings but unfortunately the scrolling works only with two fingers. I am quite used to doing that with one finger. Is it still possible to do that?

1 Answer 1


You should be able to change that in Gnome's Control Center. Run gnome-control-center or choose settings from the menu. Then, go into the 'Mouse & Touchpad' section and switch to edge scrolling in the 'Touchpad' tab:

enter image description here

If that doesn't work, you can try and set it manually. Edit or create the file /usr/lib/X11/xorg.conf.d/10-synaptics.conf and make it look like this:

Section "InputClass"
    Identifier "touchpad catchall"
    MatchIsTouchpad "on"
    MatchDevicePath "/dev/input/event*"
    Option        "HorizEdgeScroll"    "1"
    Option        "MaxTapTime"        "300"
    Driver "synaptics"
  • Unfortunately I don't have the tab "Touchpad" in settings. I have some settings for the touchpad in the "Mouse" tab. The available options there are: Tap to click, Two finger scroll, Content sticks to fingers, Disable while typing. I guess I need to set the options into /etc/X11/xorg.conf.d/ ?
    – tftd
    Oct 8, 2013 at 15:21
  • @tftd could you add a screenshot? What if you just disable two finger scroll?
    – terdon
    Oct 8, 2013 at 15:22
  • There you go img9.imageshack.us/img9/3461/fqpk.png .Nothing happens when I disable the two finger scroll. I can still scroll with two fingers and can't scroll with one.
    – tftd
    Oct 8, 2013 at 15:28
  • Perhaps you need to restart the trackpad driver somehow for the settings to take effect. Try rebooting just in case. If that doesn't work, yes, you'll have to do it manually. See updated answer.
    – terdon
    Oct 8, 2013 at 15:32
  • I tried this but for some reason it's not working as well. I'm not sure if that file in /etc/X11/xorg.conf.d/10-synaptics.conf is being loaded. How could I check that?
    – tftd
    Oct 8, 2013 at 21:36

You must log in to answer this question.

Not the answer you're looking for? Browse other questions tagged .