1

I have Ubuntu 12.10 on my client system. I have an error /etc/sudoers is owned by uid 1000 should be 0. I tried booting from an Ubuntu live CD and tried:

sudo chown root:root /etc/sudoers

sudo chmod 440 /etc/sudoers 

and

sudo chown 0.0 /etc/

But it is not working. It continuously gives an error:

sudo : /etc/sudoers is owned by uid 1000 should be 0.

How can I resolve this problem?

migrated from serverfault.com Oct 8 '13 at 13:27

This question came from our site for system and network administrators.

  • You don't need to chroot to do this (I assume you have if you get this error on a live CD). Just mount the / drive and run chmod directly. – terdon Oct 8 '13 at 14:12
  • For the future: never edit sudoers directly. Always use visudo. – Gilles Oct 8 '13 at 22:03
4

You should already be root on the live cd and can leave out the sudo part. Run chown root:root /etc/sudoers to fix. Alternatively boot into recovery to get a root shell.

2

I'm guessing you did the chown on the copy on the live system. You need to do it on your installed system instead, the path will probably be /media/something/etc/sudoers. At least if you use the GUI to mount the drive.

Alternatively, you could boot the system into rescue mode (should be an option at the GRUB prompt), that will hopefully give you a root shell—at which point you can just do chown root:root /etc/sudoers.

1

If this problem isn't a subtlety of running a live CD, as other answers have already discussed, there might be something wrong with your root account.

Check your root entry in /etc/passwd. The third and fourth fields (separated by a colon) should both be 0; something like this:

root:x:0:0:root:/root:/bin/bash

If root has somehow gotten UID 1000, then it makes sense why chown root:root /etc/sudoers set the ownership to 1000. Then the problem becomes changing the root account to be UID 0, and then the much harder problem of determining why did the root account change to begin with.

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy