2

I'm trying to install programs but no matter what program I try installing I get the following error. For example I downloaded skype 'skype-debian_4.2.0.11-1_i386.deb' and ran the command:

$ cd downloads

And then:

$ sudo apt-get install skype-debian_4.2.0.11-1_i386

And I get the following error:

Reading package lists... Done
Building dependency tree
Reading state information... Done
E: Unable to locate package skype-debian_4.2.0.11-1_i386
E: Couldn't find any package by regex 'skype-debian_4.2.0.11-1_i386'

I'm running CrunchBang. In the sources.list file it says:

## CRUNCHBANG
## Compatible with Debian Wheezy, but use at your own risk.
deb http://packages.crunchbang.org/waldorf waldorf main
#deb-src http://packages.crunchbang.org/waldorf waldorf main

## DEBIAN
deb http://http.debian.net/debian wheezy main contrib non-free
#deb-src http://http.debian.net/debian wheezy main contrib non-free

## DEBIAN SECURITY
deb http://security.debian.org/ wheezy/updates main
#deb-src http://security.debian.org/ wheezy/updates main

And in the folder there is one file called google-chrome.list and it says in it

### THIS FILE IS AUTOMATICALLY CONFIGURED ###
# You may comment out this entry, but any other modifications may be lost.
deb http://dl.google.com/linux/chrome/deb/ stable main

EDIT #1

When I try to run the command:

$ sudo gdebi skype-debian_4.2.0.11-1_i386.deb

I get this:

Reading package lists... Done
Building dependency tree    
Reading state information... Done
Building data structures... Done 
This package is uninstallable
Wrong architecture 'i386'
  • 2
    For the first one, you are using the wrong command; you want to use dpkg -i skype-debian_4.2.0.11-1_i386.deb. For the second one, can you provide your /etc/apt/sources.list and the contents of all files under /etc/apt/sources.list.d? – Renan Oct 7 '13 at 21:24
  • @Renan I've updated the information you wanted me to in the op. – user2612619 Oct 7 '13 at 21:35
4

Problem 1

apt-get is for downloading and installing packages from the Debian repositories. It is not for installing local .deb files. For that, you should use gdebi instead:

sudo gdebi skype-debian_4.2.0.11-1_i386

or, for a graphical interface

sudo gdebi-gtk skype-debian_4.2.0.11-1_i386

I haven't used CrunchBang but almost certainly, simply double clicking the installer should let you install it. It should automatically open in gdebi-gtk.

Alternatively, you could install directly with dpkg but this is not recommended (you are more likely to have dependency problems, version issues etc) :

sudo dpkg -i skype-debian_4.2.0.11-1_i386

Problem 2

This is why it is important to give us the background on what you've done. Here's what I think happened. You followed a tutorial in order to install skype. Since that is a 32bit application and you seem to be running a 64bit system, the common procedure is to enable multi-arch. This is done with the command sudo dpkg --add-architecture. For some reason, you seem to have run

sudo dpkg --add-architecture asdf

Thiw will cause apt-get to look for packages in a directory on the repository called binary-asdf which does not exist.

To fix these errors, run this command

sudo dpkg --remove-architecture asdf

Then, run

sudo apt-get update

It should finish with no errors.

  • For the first part when installing with gdebi I get the error 'This package is uninstallable Dependency is not satisfiable: libasound2 (>= 1.0.16)'. Also when I remove the architecture and then update I get the same error. – user2612619 Oct 8 '13 at 1:22
  • @user2612619 please post a new question, asking how to install skype. Since your original error has been resolved, any new ones should be addressed in new questions. As for the second, edit your question and show the output of dpkg --print-foreign-architectures. – terdon Oct 8 '13 at 1:25
  • Oh my am I stupid. I thought 'asdf' would be the architecture that I used (in this case I thought it was i386. I can now update but I'll update with what happens when I try installing skype or any other program. – user2612619 Oct 8 '13 at 1:30
  • @user2612619 the SE sites work in a different way than forums. We don't use a single thread to for follow up problems. The idea here is to have specific questions with specific answers. If my answer solves the problem you posted about, please mark it as accepted and then open a new question for the next bit. – terdon Oct 8 '13 at 1:32
  • It's not solved, I am still unable to install any programs (ie skype) or any other program. – user2612619 Oct 8 '13 at 1:37
0

Do this trick

sudo apt-add-repository "deb http://archive.canonical.com/ $(lsb_release -sc) partner"
sudo apt-get update && sudo apt-get install skype

It works for me.

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.