I've had the same problem in both Ubuntu 12.10 and Linux Mint 15. I've tried taking my Acer laptop apart and cleaned and resat the GPU and CPU heatsinks and fan (with fresh heat paste of course).

$ sensors
Adapter: Virtual device
temp1:        +64.0°C  (crit = +102.0°C)
temp2:        +43.0°C  (crit = +96.0°C)

Adapter: ISA adapter
Core 0:       +66.0°C  (high = +95.0°C, crit = +105.0°C)
Core 2:       +63.0°C  (high = +95.0°C, crit = +105.0°C)

It's helped a little, my 'temp 2' used to be higher, and it took much longer to cool down if I ran a game, but my CPUs are still running very hot (the above is just with chromium and a terminal open in Cinammon). I've installed the latest proprietary drivers (not the ones you can select in 'drivers,' which broke X). Instead I'm running 331.

$ inxi -Gxx
Graphics:  Card: NVIDIA GT216M [GeForce GT 320M] bus-ID: 02:00.0 
           X.Org: 1.13.4 drivers: nvidia (unloaded: fbdev,vesa,nouveau) Resolution: 1366x768@60.0hz 
           GLX Renderer: GeForce GT 320M/PCIe/SSE2 GLX Version: 3.3.0 NVIDIA 331.13 Direct Rendering: Yes

Despite being 'better than before' my computer still crashes not long after starting any kind of graphics intensive task. Even the game 'Thomas is not along' (seems relatively simple visually) is too much. Now it takes about 20 minutes to crash (rather than 5), but I really would like my laptop to stop overheating so easily. =(

I tried installing Bumblebee as I read it's due to some kind of issue that forces the GPU to run but, again, X stopped working. I uninstalled it, and have since spent time trying to find a solution. My googlefu is failing me, so I turn to you for help. Do I need to step back from my nvidia updates to get bumblebee working? Is there a more up to date version I should be using?

Maybe it's not the GPU (I would have thought that's what temp 2 is reading, and it's cool). Maybe something is happening to make my CPU run through the roof?

$ inxi -fxz
CPU:       Dual core Intel Core i5 CPU M 430 (-HT-MCP-) cache: 3072 KB bmips: 9043.48 
           Clock Speeds: 1: 1199.00 MHz 2: 1199.00 MHz 3: 1199.00 MHz 4: 1199.00 MHz
           CPU Flags: fpu vme de pse tsc msr pae mce cx8 apic sep mtrr pge mca cmov pat pse36 clflush dts 
           acpi mmx fxsr sse sse2 ss ht tm pbe syscall nx rdtscp lm constant_tsc arch_perfmon pebs bts rep_good 
           nopl xtopology nonstop_tsc aperfmperf pni dtes64 monitor ds_cpl vmx est tm2 ssse3 cx16 xtpr pdcm sse4_1 sse4_2 popcnt 
           lahf_lm ida arat dtherm tpr_shadow vnmi flexpriority ept vpid 

EDIT: I just tried the 'Advanced' install here: https://wiki.ubuntu.com/Bumblebee installing bumblebee-nvidia, virtualgl and virtualgl-libs-ia32 and had the same problem (X server stopped working).

  • The temperatures you have posted are not that high. Are you sure this is a heating issue? What temperatures do you get before crashing? Do the fans speed up when it gets hotter? What CPU governor do you have enabled? Post the output of cat /sys/devices/system/cpu/cpu0/cpufreq/scaling_governor. – terdon Oct 6 '13 at 14:24
  • Yes, it's definitely a heating issue. The output is 'on demand' The fan (there's only one with two heatsinks - one for the CPU and one for the GPU) does speed up as it gets hotter, which it does quickly when doing anything even remotely graphics intensive. I just checked by running 'Thomas Was Alone' (in Steam) again, and the heat quickly ramped over about 20 minutes (the last time I check the CPUs were in the low 90s) and then the lappy crashed (did the quick overheat shutdown). Thanks for the help, any other questions? – Tamsyn Michael Oct 6 '13 at 15:25
  • Nope, sounds like you're absolutely right and it is a heating issue. If you can hear the fans speed up and you have ondemand and you've recently cleaned/changed heat paste, it sounds like a hardware issue. Bear in mind that you have a 500 euro laptop. Sounds like your best bet is to get an external cooler. – terdon Oct 6 '13 at 15:32
  • =) - you're being kind. 500 euro is overvaluing her by a fair bit. I'll look into the external cooling option. At least a clean laptop will make that more effective. – Tamsyn Michael Oct 6 '13 at 15:41
  • Hi! Have you found a solution to your issue? I'm encountering something similar with a later version of an Acer laptop: unix.stackexchange.com/questions/129214/… . Thanks for your input. – ChrisR May 19 '14 at 14:51

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Browse other questions tagged or ask your own question.