0

I created virtual machine out of WordPress turnkey appliance (I believe it's based on Ubuntu) inside Virtual Box. I am able to mount a folder on turnkey from the host (Windows7) manually.

So I added this to the /etc/fstab

//10.1.1.4/d/data/Dropbox/onlinebackup/projects/newplugin /var/www/wordpress/wp- content/plugins/newplugin cifs username=user,password=password but the mount doesn't work after starting the virtual machine. Interestingly when the machine is up and running I can ssh there and run mount -a and the Windows directory is mounted.

Any idea what is happening and how to fix it?

  • 2
    Dont really know your OS that well so this is a guess - I'd be looking at when networking starts vs when "mount -a" is called by the boot sequence. There's usually a pivot/remount of the root device follows by a "mountall" in most builds... The later mountall after networking sometimes is triggered by NFS mount presence or so forth. Not amazingly helpful and I sure dont know how to debug your boot sequence. Alternative "bodge" is to put mount -a in your /etc/rc.local (or OS equivalent) which will just get run at the end of all init sequences. – iain Oct 6 '13 at 2:57
  • I was also thinking of adding mount -a into rc.local but I find it as a workaround only. – Radek Oct 6 '13 at 3:28
  • @iain, ubuntu doesn't actually use the traditional mountall. Its version in upstart runs as a daemon waiting for the underlying devices ( or network ) to come up, then mounts them, after mounting any other mounts it depends on. – psusi Oct 6 '13 at 3:33
  • 2
    To amplify @iain, since mount -a works properly at some time after boot, it is almost certainly a sequencing issue. You might try adding bootwait to the fstab options as described in fstab(5). – msw Oct 6 '13 at 3:36
  • @msw: it seems to me that bootwait is not available for me. – Radek Oct 6 '13 at 3:50
0

TurnKey Linux is currently based on Debian (v13.x is based on Debian Wheezy; previous v12.x based on Squeeze; prior to that it was Ubuntu based - v11.x based on Lucid).

I have read that editing /etc/default/rcS and adding:

ASYNCMOUNTNFS=no

resolves the issue. However, others have complained that their boot hangs or that their filesystem mounts read-only after that adjustment, so I'm not sure...

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.