3

I installed a fresh Debian 7 install, but it freezes from time to time, and when it happens (quite often indeed) only the mouse can move around but everything is blocked. All I can do is restart.

  • I would like to debug this problem, where should I look?
  • I'm using gnome3.
  • I have activated X kill by Ctrl+Alt+BackSpace and it does not work.
  • Ctrl+Alt+F2 does not do anything either.
  • But I can reboot with Alt+SysRq+B

output from ~/.xsession_errors

/etc/gdm3/Xsession: Beginning session setup...
localuser:simona being added to access control list
openConnection: connect: No such file or directory
cannot connect to brltty at :0
GNOME_KEYRING_CONTROL=/home/simona/.cache/keyring-tnSq4q
GNOME_KEYRING_CONTROL=/home/simona/.cache/keyring-tnSq4q
GPG_AGENT_INFO=/home/simona/.cache/keyring-tnSq4q/gpg:0:1
GNOME_KEYRING_CONTROL=/home/simona/.cache/keyring-tnSq4q
GPG_AGENT_INFO=/home/simona/.cache/keyring-tnSq4q/gpg:0:1
SSH_AUTH_SOCK=/home/simona/.cache/keyring-tnSq4q/ssh
GNOME_KEYRING_CONTROL=/home/simona/.cache/keyring-tnSq4q
GPG_AGENT_INFO=/home/simona/.cache/keyring-tnSq4q/gpg:0:1
SSH_AUTH_SOCK=/home/simona/.cache/keyring-tnSq4q/ssh
Initializing tracker-store...
Tracker-Message: Setting up monitor for changes to config file:'/home/simona/.config/tracker/tracker-store.cfg'
** Message: applet now removed from the notification area
Initializing tracker-miner-fs...
Tracker-Message: Setting up monitor for changes to config file:'/home/simona/.config/tracker/tracker-miner-fs.cfg'
Starting log:
  File:'/home/simona/.local/share/tracker/tracker-miner-fs.log'
Tracker-Message: Setting up monitor for changes to config file:'/home/simona/.config/tracker/tracker-store.cfg'
Starting log:
  File:'/home/simona/.local/share/tracker/tracker-store.log'
** Message: Stopping applet secret agent because GNOME Shell appeared
** Message: applet now embedded in the notification area
Window manager warning: CurrentTime used to choose focus window; focus window may not be correct.
Window manager warning: Got a request to focus the no_focus_window with a timestamp of 0.  This shouldn't happen!
Fontconfig warning: Directory/file mtime in the future. New fonts may not be detected
Fontconfig warning: Directory/file mtime in the future. New fonts may not be detected
Fontconfig warning: Directory/file mtime in the future. New fonts may not be detected
WARNING : Testing for expected AutostartCondition failed: Got (None)
Traceback (most recent call last):
  File "/usr/lib/python2.7/dist-packages/gtweak/utils.py", line 152, in uses_autostart_condition
return asc.split(" ", 1)[0] == autostart_type
AttributeError: 'NoneType' object has no attribute 'split'

(gnome-tweak-tool:3655): Gtk-CRITICAL **: gtk_widget_get_preferred_height_for_width: assertion `width >= 0' failed

(gnome-tweak-tool:3655): Gtk-CRITICAL **: gtk_widget_get_preferred_height_for_width: assertion `width >= 0' failed

(gnome-tweak-tool:3655): Gtk-CRITICAL **: gtk_widget_get_preferred_height_for_width: assertion `width >= 0' failed

(gnome-tweak-tool:3655): Gtk-CRITICAL **: gtk_widget_get_preferred_height_for_width: assertion `width >= 0' failed

(gnome-tweak-tool:3655): Gtk-CRITICAL **: gtk_widget_get_preferred_height_for_width: assertion `width >= 0' failed

(gnome-tweak-tool:3655): Gtk-CRITICAL **: gtk_widget_get_preferred_height_for_width: assertion `width >= 0' failed

(gnome-tweak-tool:3655): Gtk-CRITICAL **: gtk_widget_get_preferred_height_for_width: assertion `width >= 0' failed

(gnome-tweak-tool:3655): Gtk-CRITICAL **: gtk_widget_get_preferred_height_for_width: assertion `width >= 0' failed

(gnome-tweak-tool:3655): Gtk-CRITICAL **: gtk_widget_get_preferred_height_for_width: assertion `width >= 0' failed

(gnome-tweak-tool:3655): Gtk-CRITICAL **: gtk_widget_get_preferred_height_for_width: assertion `width >= 0' failed

(gnome-tweak-tool:3655): Gtk-CRITICAL **: gtk_widget_get_preferred_height_for_width: assertion `width >= 0' failed

(gnome-tweak-tool:3655): Gtk-CRITICAL **: gtk_widget_get_preferred_height_for_width: assertion `width >= 0' failed

(gnome-tweak-tool:3655): Gtk-CRITICAL **: gtk_widget_get_preferred_height_for_width: assertion `width >= 0' failed

(gnome-tweak-tool:3655): Gtk-CRITICAL **: gtk_widget_get_preferred_height_for_width: assertion `width >= 0' failed

(gnome-tweak-tool:3655): Gtk-CRITICAL **: gtk_widget_get_preferred_height_for_width: assertion `width >= 0' failed

(gnome-settings-daemon:3345): PackageKit-WARNING **: couldn't parse execption 'GDBus.Error:org.gtk.GDBus.UnmappedGError.Quark._pk_5ftransaction_5ferror.Code4: GetDistroUpgrades not supported by backend', please report

(gnome-settings-daemon:3345): updates-plugin-WARNING **: failed to get upgrades: GDBus.Error:org.gtk.GDBus.UnmappedGError.Quark._pk_5ftransaction_5ferror.Code4: GetDistroUpgrades not supported by backend
Fontconfig warning: Directory/file mtime in the future. New fonts may not be detected    

output from /var/log/Xorg.0.log

http://www.fileswap.com/dl/IdLDxQnQ5N/


output from lspci | grep VGA | cut -d' ' -f1 | xargs -n1 lspci -v -s

00:10.0 VGA compatible controller: NVIDIA Corporation C73 [GeForce 7100 / nForce 630i] (rev a2) (prog-if 00 [VGA controller])
    Subsystem: Samsung Electronics Co Ltd Device b04e
    Flags: bus master, 66MHz, fast devsel, latency 0, IRQ 10
    Memory at f1000000 (32-bit, non-prefetchable) [size=16M]
    Memory at d0000000 (64-bit, prefetchable) [size=256M]
    Memory at f0000000 (64-bit, non-prefetchable) [size=16M]
    [virtual] Expansion ROM at 80000000 [disabled] [size=128K]
    Capabilities: <access denied>
    Kernel driver in use: nouveau

Solution:

I think I have solved my problem, by installing the proprietary nvidia drivers, with a lot of help from alex!

My debian has not freezed yet.

  • For a start, tell us what desktop environment or WM you use. Then, check ~/.xsession-errors and /var/log/Xorg.0.log. Next time it freezes, try dropping to a tty (hit Ctrl+Alt+F2). Does that work? Can you log in? Also activate a shortcut that kills the X server, does that work? – terdon Oct 4 '13 at 3:25
  • 1
    Can you figure out a way to remove gnome-tweak-tool? That seems to be the devil.. – Varad Oct 4 '13 at 6:33
  • 1
    can you post the output of lspci | grep VGA | cut -d' ' -f1 | xargs -n1 lspci -v -s. That will tell us what video card(s) and driver(s) you have. – cas Oct 4 '13 at 9:04
  • 1
    Try switching to the proprietary Nvidia driver and see if that helps. – Faheem Mitha Oct 4 '13 at 9:46
  • 1
    @simona: See wiki.debian.org/NvidiaGraphicsDrivers I haven't used these instructions myself, so I can't say whether they will work. In the past I've used module-assistant to compile the nvidia kernel modules, but these instructions may be better – Faheem Mitha Oct 4 '13 at 10:52
1

Another solution is to use the nouveau driver without render acceleration.

  1. Open /etc/default/grub
  2. Edit the line GRUB_CMDLINE_LINUX

    GRUB_CMDLINE_LINUX="nouveau.noaccel=1"

  3. Execute update-grub

  4. Reboot

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.