Every time I plug in any wired mouse recently, I get similar to the below on VCS1:

[1443270.286164] usb 6-1: new low-speed USB device number 15 using uhci_hcd
[1443270.454270] usb 6-1: New USB device found, idVendor=045e, idProduct=0083
[1443270.461874] usb 6-1: New USB device strings: Mfr=1, Product=2, SerialNumber=0
[1443270.469328] usb 6-1: Product: Basic Optical Mouse
[1443270.476877] usb 6-1: Manufacturer: Microsoft
[1443270.501140] input: Microsoft Basic Optical Mouse as /devices/pci0000:00/0000:00:1d.0/usb6/6-1/6-1:1.0/input/input26
[1443270.509327] hid-generic 0003:045E:0083.000F: input,hidraw0: USB HID v1.10 Mouse [Microsoft Basic Optical Mouse] on usb-0000:00:1d.0-1/input0

.. but no mouse functionality.

The last time I spent some trying to solve this, the final line that is now missing from the above, was No input driver specified, ignoring this device

I haven't tried a computer reboot, because I am interested in using this opportunity to become more acquainted with the mouse subsystem(s) of Linux.

Found Restart USB mouse driver? while writing up this question, but not sure how to try steps 2 & 3 of what this OP tried (Have restarted X, however - No change).

What should I look at next?

  • You should look at your X configuration (if you still have one, and its not all auto-probed), and possibly udev. Does X show anything in its logs? What does xinput list show? – derobert Oct 3 '13 at 21:55
  • Sorry - What should I be looking for in the X Config file (Which is where?); Where is the X logs, and the xinput.list? – user66001 Oct 3 '13 at 21:57
  • X config would be in /etc/X11/xorg.conf or /etc/X11/xorg.conf.d. X logs are /var/log/Xorg.*.log. xinput list is a command you run inside an xterm (or gnome-terminal, or konsole, etc.) – derobert Oct 3 '13 at 21:58
  • By the way, please remember to go and accept the answer that you got to your other question. Assuming it answered it that is but your comments seem to imply that it did. – terdon Oct 3 '13 at 22:06
  • derobert - I don't have a /etc/X11/xorg.conf (./X11 Directory just contains XVESA, app-defaults, fs & xkb directories); /var/log/Xorg.0.log only contains entries about the touchpad; Running xinput in ROXTerm reports command not found @terdon - Unfortunately there is still clarifications in the comments, that haven't been answered, and feel that would complete the answer to the question, being the reason I haven't done so yet. – user66001 Oct 3 '13 at 22:28

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Browse other questions tagged or ask your own question.