I did an upgrade from Xubuntu 12.04 to 12.10, and I can't connect to the internet now.

When I press the network button on the panel, I see "No network devices available" on top (greyed out), then "VPN Connections", "Enable Networking" with a checkmark next to it, "Information" (greyed out) and "Edit".

Here's the output from some commands that seem relevant:

 ~ % lspci | grep -i ethernet
03:00.0 Ethernet controller: Realtek Semiconductor Co., Ltd. RTL8111/8168B PCI Express Gigabit Ethernet controller (rev 07)
~ % lspci | grep -i network
02:00.0 Network controller: Intel Corporation Centrino Wireless-N 1030 (rev 34)
~ % sudo lshw -C network
PCI (sysfs)
  *-network UNCLAIMED
       description: Network controller
       product: Centrino Wireless-N 1030
       vendor: Intel Corporation
       physical id: 0
       bus info: pci@0000:02:00.0
       version: 34
       width: 64 bits
       clock: 33MHz
       capabilities: pm msi pciexpress bus_master cap_list
       configuration: latency=0
       resources: memory:f7c00000-f7c01fff
  *-network UNCLAIMED
       description: Ethernet controller
       product: RTL8111/8168B PCI Express Gigabit Ethernet controller
       vendor: Realtek Semiconductor Co., Ltd.
       physical id: 0
       bus info: pci@0000:03:00.0
       version: 07
       width: 64 bits
       clock: 33MHz
       capabilities: pm msi pciexpress msix vpd bus_master cap_list
       configuration: latency=0
       resources: ioport:e000(size=256) memory:f0004000-f0004fff memory:f0000000-f0003fff
~ % uname -a
Linux bleen 3.5.0-030500-generic #201207211835 SMP Sat Jul 21 22:35:55 UTC 2012 x86_64 x86_64 x86_64 GNU/Linux
~ % ifconfig 
lo        Link encap:Local Loopback
inet addr: Mask: inet6 addr: ::1/128 Scope:Host UP LOOPBACK RUNNING MTU:16436 Metric:1 RX packets:472 errors:0 dropped:0 overruns:0 frame:0 TX packets:472 errors:0 dropped:0 overruns:0 carrier:0 collisions:0 txqueuelen:0 RX bytes:35080 (35.0 KB) TX bytes:35080 (35.0 KB) ~ % ifconfig eth0 up eth0: ERROR while getting interface flags: No such device

I think that UNCLAIMED means I don't have a driver for the Ethernet controller. It seems that the driver should be called something including 816 (I don't remember where I found that), and it does seem to be missing:

~ % lsmod | grep 816
~ % 

I tried downloading and installing the driver (after moving on a USB stick from a computer with a connection), but I get this issue:

~/r8168-8.037.00 % sudo ./autorun.sh 
Check old driver and unload it.
Build the module and install
make: * /lib/modules/3.5.0-030500-generic/build: No such file or directory.  Stop.
make1:  [clean] Error 2
make: ** [clean] Error 2

Not sure what to do next.

  • 1
    For your last issue (when compiling the module from source), you probably need to install the kernel headers: sudo apt-get install linux-headers-$(uname -r) and try again.
    – Joseph R.
    Commented Oct 3, 2013 at 19:07
  • @JosephR. That tells me linux-headers-3.5.0-030500-generic is already the newest version. and doesn't do anything.
    – weronika
    Commented Oct 3, 2013 at 19:15
  • Please check that both these directories are available on your system: /lib/modules/3.5.0-030500-generic and /usr/src/linux-headers-3.5.0-030500-generic.
    – Joseph R.
    Commented Oct 3, 2013 at 19:19
  • @JosephR. They are. The first one just doesn't have a build subdirectory in it.
    – weronika
    Commented Oct 3, 2013 at 19:21
  • 1
    On my system (Debian Wheezy), build is actually a symlink to /usr/src/linux-headers-$(uname -r). So simply add the symlink: sudo ln -sv /usr/src/linux-headers-$(uname -r) /lib/modules/$(uname -r)/build
    – Joseph R.
    Commented Oct 3, 2013 at 19:23

3 Answers 3


This question turned out to have two answers, both suggested by @JosephR in the comments.

1) Fixing the /lib/modules/3.5.0-030500-generic/build: No such file or directory error while trying to install the ethernet driver just needed a sudo ln -sv /usr/src/linux-headers-$(uname -r) /lib/modules/$(uname -r)/build - after I did that, the driver install from source worked fine, and I got an ethernet connection.

(Presumably repeating the process with the driver for the wireless controller would have made that work too, but I didn't actually try, due to solution #2.)

2) It turned out that if I just booted with the other kernel that was already installed (3.5.0-41-generic instead of 3.5.0-030500-generic - I don't actually know what the difference is), both the ethernet and the wireless worked fine!

It also solved some other problems I was having after the upgrade. So I changed the default boot kernel to that, and will probably stick with that unless I run into other issues.


I had faced a similar problem when a working wifi connection stopped working after a dist-upgrade. (I have HP Pavilion g6, the driver being ralink3290). The problem was that the upgrade modified the module and so the driver that was being used was not the same as was supposed to be used by my system.

  • Use this command to see which wireless controller hardware you are using

    $ lspci | grep Network

    The output for me was: Network controller: Ralink corp. RT3290

All I had to do was:

  • Check if the conflicting wireless drivers are still blacklisted

    $ sudo gedit /etc/modprobe.d/blacklist.conf`
  • Add these lines, if not already present:

    # Conflicting wireless drivers with rt3290sta
    blacklist rt2800pci
  • Load the correct module on boot

    $ sudo gedit /etc/modules`

(Check for your own module as per your drivers)

  • Add this line at the end of the file: rt3290sta

  • Update the modification you just made:

    $ sudo update-initramfs -u`
  • Restart your system

    $ sudo shutdown -r now

You should now be able to view the wireless connections in the Network Manager.


I need to give an updated answer to this question, because this also happened to me, this year. In my case, after the last update to the Kernel all older (discontinued) firmware was dropped and so I was left without it.

First, YES, UNCLAIMED means: no driver (or firmware interface) found that are registered with the OS to handle the device.

See the output of:


enter image description here

You can now go the GIT Route, clone the repository, find the appropriate firmware and install it:

sudo cp iwlwifi-*.ucode /lib/firmware

Or see if the manufacturer is listed and indexed here: wireless wiki drivers

enter image description here

After restarting:

enter image description here

As we can see Linux tried to use newer drivers but found only the iwlwifi-6000-4.ucode


  • Do you have any suggestion if my min, max and nothing in between supported versions are not found in git repo?
    – popeye
    Commented Jul 16, 2022 at 12:18

You must log in to answer this question.

Not the answer you're looking for? Browse other questions tagged .